Approval for VAT returns with HRMC not working

i have requested to be authorized to use qhickfile for VAT returns but so far have not received approval. My VAT number is correct- what to do?

this is the message that has been like that there for weeks:
You are not yet authorised to view this report for the VRN 256 4443 95 . Please ensure your VAT number is correct and you have connected the corresponding HMRC Tax Account. If you have recently enrolled on the MTD scheme please allow 24 hours for HMRC systems to update.

If you received the email from hmrc that you are now set up for mtd then it’s likely you haven’t set up the quickfile link correctly.

When setting up the connection
Did you select individual or organisation? And are you a sole trader or company?

When setting the link up did you get redirected to hmrc to enter a pass code. And if so did it return you to quickfile once completed?

If you have tried linking accounts more than once have you disconnected the old attempts? Having more than one listed will stop others working.

Paul, thanks for the reply - i have not received any email from HRMC - i entered the information that was asked on the screen through quckfile website - i have Ltd company. Provided my VAT number.

i do not remember setting up any pass code.

i only tried so far one time

ok i have repeated adding my Ltd company again and was asked to enter my HRMC account number pin where after i got text with the code which got me into HRMC website where I granted and after that i returned to quickfile webiste. now i have two HMRC Tax Accounts with the same name both of them saying I am not yet authorised to view this report

Hi @basaricr

If you’re seeing a message saying you’re not authorised, it’s typically one of a few issues:

  • You’ve not enrolled on MTD with HMRC

  • You have enrolled on MTD, but not received the confirmation email (can take up to 72 hours)

  • The tax account you’ve linked isn’t the one with access to VAT on the HMRC website.

You can’t have two accounts linked or both won’t work. Delete the old one and try and connect again.

This topic was automatically closed after 7 days. New replies are no longer allowed.