Changing time denomination on future sales invoices

When I try to change the time denomination from hours to days on future invoices it applies it to past invoices as well. How do I change this so it only changes future sales invoices?

I’m afraid the time denomination is a global account setting so would apply to all invoices old and new. All it really does is change the itemised table header name.

I’m happy to update this to a feature request for now and if it receives further interest we can consider having this set individually against each invoice.

Great, thanks. It would be much simpler for me to now change from hours to the number of days used at a certain rate, but would obviously need previous invoices to stay the same.


Fairly new to quickfile, but finding it would be very valuable if I could switch between days and hours without affecting all previous invoices. I have one fairly substantial client who buys blocks of days and insists on having this on their quote and invoices, but everyone else is hourly. Hope you might have had further interest in such a function?
Many thanks

I’m afraid we only store this as a global account setting we don’t store at the invoice level.

That said I believe that you could setup a custom trading style and assign this just to your one client to achieve what you’re after. I will post some instructions shortly.


Go to sales >> Invoice customisation.

Now clone the standard invoice template.

Rename the template so you can easily identify it’s purpose.

Now change the denomination label for this template to “Days”.

Now go to Accounts >> Design Customisation and select the option “Additional Trading Styles”.

Click the green button to setup a new style.

You can now setup your new trading style making sure to utilise the “Daily denomination” template created earlier.

Locate the client you want to assign this template to and go modify the client details. At the bottom of this screen you can now assign the trading style.

Now when you invoice this client they will have a header for “Days” rather than “Hours”.

Hope that helps, let me know if you get stuck.