Creating tagging rules

When I tag a transfer from my bank current account to my liquidity manager account it asks me if I want to create a rule, which I agree to by checking the box. The rule is supposed to apply to anything in the account that says ‘From…’ or ‘To…’ (there doesn’t seem to be any option to change the wording of the rule incidentally). The problem is that nothing seems to happen. I think when I’ve created other rules the ‘Tag Me’ button changes to ‘Confirm’, but it doesn’t in the transfer cases. Please advise. Thanks, Tim.

Hi Tim,

The “Confirm” button is correct - that’s what should appear.

If you need to change the text, hover over ‘Banking’ at the top of the screen, and select ‘Bank Tagging Rules’. It’s worth checking these, as transfers are no different, and should be tagged if the rule is matched.

Take a look, and make sure the ‘Match Text’ is what’s actually showing up on your banking screen. Here’s an example of my PayPal transfer rule for payments going out from the bank to the PayPal account.

Thanks for that. Yes, I can now see the bank tagging rules listed and how to edit them. The bank transfer rules all seem to be set up in there as they should be, I’ve even set up a new one and it tells me it’s identified 20 matching transactions, but nothing seems to happen - the ‘Confirm’ button doesn’t appear on these.

Hmm, that’s a bit odd. Would you mind posting a screenshot of the rule, and of the bank transaction?

Just trying to get an idea of what it should be doing, and maybe why it isn’t.

I’m not really comfortable with posting screenshots of the bank account details.

I was after more of just details of the bank tagging rule and just the line (no monetary values etc).

I don’t actually work for QuickFile, so maybe @Glenn will be able to help you shortly :smile:

Thanks for your help anyway. I don’t think I can post the rule without info that’s probably best not to be public.

Would you prefer to send me a PM? I’m happy to look at it for you :smile:
(Click my picture, click ‘Private Message’)

Just a note… it won’t retrospectively flag any transactions previously entered and will only apply to newly imported transactions. If it’s matching 20 in the rule editor it sounds like you have the rule wired up correctly.

Try copying the description of one of these existing items and create a new transaction, it should appear orange with a confirm button.

Yes, thanks Glenn. I’ve tried manually entering a new transaction and it immediately flags up the ‘Confirm’ tab. So the problem is clearly that I’d imported the bank statement before setting the rules.

1 Like

As easy as that! I always seem to miss the simple points! Thanks @Glenn :wink:

No worries! It’s not always that obvious, many times I have had to check the code to see how things work :smile:

Hi Glenn, It would be really useful to have the ability to scan untagged transactions already imported with a new rule. Is this something being considered?

@mgbooks, it would be useful but it’s not something we’ll implement for 2 reasons.

  1. It would in some circumstances put excessive load on the server. Say you have 1,000 matching entries (rare but quite possible) it would try to instantly tag 1,000 items and could cause some nasty performance issues.

  2. Any mistake could have significant impact on your books and really screw up a lot of data. It would take a long time to unwind these mispostings.

This topic was automatically closed after 7 days. New replies are no longer allowed.