HOME / COMMUNITY Switch to knowledge base

Enabling 2FA on community.quickfile.co.uk account


#1

Hi,

I’ve just enabled 2FA on my main login for “[mycompany].quickfile.co.uk” and that works fine.

However, when I try to enable 2FA on my community.quickfile.co.uk account I get an error “Invalid authentication code. Each code can only be used once.”.

To reproduce:

  • Log in to the community site as usual
  • Click on your profile icon, then “Preferences”
  • Click the icon next to “Enable two factor authentication for enhanced account security”
  • Scan the QR code using the Google Authenticator app (I’m using the iPhone app)
  • Enter the current code
  • The “Invalid authentication code. Each code can only be used once.” error appears

Could you confirm if I’m doing something wrong or whether this is an issue with 2FA on the community.quickfile.co.uk site?

I actually tried to set up 2FA on the community site before the accounting site and I got the same error then, if that makes any difference…

Cheers,

Mike


#2

Hi @kingsland

I’ve managed to replicate this. I have asked someone to take a look and will come back to you shortly.


#3

You are getting the code from Google Authenticator and not using the backup code, right?

The Google authenticator app generates a new code every 30 seconds and can be used only once. You cannot log in twice in 30 seconds.

Does this explain what you are seeing?

EDIT: Oops. I’m having the same problem. I just updated to latest and the problem persists. I’ll report back later.


#4

Thanks, @kingsland! The problem was that the time on the server was wrong, so the codes we were using were wrong. It’s working here now.


#5

Hello.

I managed to enable 2FA last night and enter the 6-digit Google Authenticator code.

Unfortunately when I tried to log in and enter the latest auth code I got exactly the same error again on the login page. I presume I hit a different server for the login, that maybe had the same time sync issue.

I couldn’t report it last night because I couldn’t log in!

It obviously worked for me this morning otherwise I wouldn’t be writing this, but is it likely to be an intermittent issue, or have you got something in place which will now enforce time sync on your servers? (e.g. NTP).

Cheers,

M


closed #6

This topic was automatically closed after 7 days. New replies are no longer allowed.