I did not add company number on set up!

I did not add the company number when I set up the account. I added it later in the management information section, but when I save it it does not save and goes back to a blank box. Not having the company number set up I am unable to add it on my invoices and estimates. Can anyone help!

You can always show more details in invoice footer.
If you go to Account Setting > Invoice Style > Invoice Labels and click on company number, it should show up on your invoices

@helen1 it should be OK now, the number was saved it just wasn’t showing in this screen for some reason…I’ve fixed this and referred the underlying problem to an engineer to look at. The answer @Accountant provided should help you with the next stage, which is getting the company number to show up on the invoice. Let me know if you need any further help!

Thank you Glen,all sorted out now!