HOME / COMMUNITY Switch to knowledge base

MDT VAT return has it been filed as not showing on reports

I tried to submit my MDT vat return this afternoon but I kept getting an error 503 message. I tried repeatedly and then out of the blue it said it had already been submitted. However when I check the reports section of my Quickfile it is not showing up. If I try to submit again it does say it has already been filed so how do I check if it is or it isn’t!

Hi @cwright2205,

Best way to check is directly with HMRC, if you log in to your government gateway account it should show up there

I’ve just had the same thing (which support is kindly looking into) but when I clicked on “Create New VAT Return” the VAT Return just submitted could be accessed on that screen.

Ive just had an email from support who advised to log onto HMRC website and check. Ive just done that and sure enough the VAT return was submitted so all good. Hope yours is okay

Very good. I have another MTD software package that I have linked the on-line record up to so I can use that to check if the VAT Return has been filed with HMRC and indeed it has. Belt and braces and all that.

Good idea, its a carry on isn’t it. Glad we are both sorted

In QuickFile if you go to Reports >> HMRC, select the tax account and then View VAT Obligations, this will give you a live view from HMRC. If it’s appearing there as filed then you can be sure it has reached HMRC.

As to why this happened, we noticed a few “Service Unavailable (HTTP 503)” errors from HMRC’s API earlier today. It seems HMRC returned this error but did actually process the return, which is odd. I know 6th and 7th of the month they tend to be under quite high load, so it may be related to that.

@Withnail we’ve manually lodged your VAT return for you.

@cwright2205 I believe you are using the VAT bridging tool? I’m happy to open a private message with you to provide any further assistance.

Thanks Glenn. The VAT Return is now where it should be.

2 Likes

This topic was automatically closed after 7 days. New replies are no longer allowed.