HOME / COMMUNITY Switch to knowledge base

MTD VAT Now Failing - API Unavailable

Hi, my last 2 MTD VAT submits were fine, but now my latest one is stuck as saved and has not been submitted to HMRC.

Any ideas?

Thanks

Hi @mphayesuk,

Have you checked your VAT settings and the connection with HMRC is all ok? Reports >> HMRC

It might be worth working through this: Making Tax Digital: Troubleshooting

Hi, thanks for your reply.

There is an error on both my accounts with you that say API is currently unavailable. HMRC site says everything is fine.

There was HMRC maintenance run yesterday but should have ended at 5pm GMT.

So either something is outstanding on HMRC side or their change updated some settings that makes Quickfile unable to connect with the API.

Thanks

Hi @mphayesuk,

Please see this link to the issue on their API status page: API Platform Status - VAT MTD Service Unavailable

:slight_smile: Thank you very much.

Hi again, quick question, my Reports >> HMRC is showing as green/good now.

Will my “saved” VAT return automatically be submitted to HMRC? or do I need to do something?

Thanks
Martin

Hi @mphayesuk

If the return is just showing as “Saved”, you will need to roll it back, and re-create it.

Ok no problem, thanks for confirming.

Hi again, I am going to need a little help and confirmation.

I rolled back the saved VAT return and when I go to create a new vat return its saying that its already been submitted to HMRC.

  1. I have checked HMRC online and the VAT return is there.
  2. How do I re-run the VAT return so everything in the accounts is lined up correctly.

Many thanks
Martin

Ok, I think I fixed it, I disabled the MTD re-ran teh VAT return and then turned MTD back on again. Should all be good now I think.

Thanks

1 Like

Hi @mphayesuk

That sounds correct :+1:

This topic was automatically closed after 7 days. New replies are no longer allowed.