HOME / COMMUNITY Switch to knowledge base

MTD won’t renew

Hi. Could anyone please help with mtd subscription. I was hoping to just renew the subscription but it seems it won’t let us. We have spoken to HMRC and they said it’s software issue.
I’ve had numerous attempts and no joy. It says bad request.
It also comes up with these messages. See pics.

It should be ok if you disconnect the failed one and leave only the “good” one. Or failing that if you disconnect both and only then connect the right one back up.

Hi. Thanks for the response. We have tried this. Same response every time. Spoke to hmrc they said it is software issue.

The standard troubleshooting recipe here is:

  • disconnect all HMRC accounts from QuickFile reports -> HMRC page
  • double check you have the correct government gateway account for VAT (done people have one for VAT and a different one for personal taxes or corporation tax - you just connect the one that is enabled for VAT)
    • if you’re logged in to tax.service.gov.uk then log out, if in doubt open a private browsing window
  • connect the correct account in QuickFile
  • check in your VAT settings that you have online filing and MTD features enabled, the right (hopefully only) tax account is selected in the drop down and your VAT number is correct

If it still doesn’t work after this then someone from QuickFile staff will probably have to take a look in the morning.

Hi @chrisangell

Sorry to hear that you’re experiencing some issues here.

Can I just check, with the “Bad Request” screenshot (the last one) - do you recall what the web address is for this page (whether it was on the HMRC website or not), and how you got there?

Hi @chrisangell,

image

You’ll need to disconnect all of the accounts (Reports > HMRC) leaving just one that has status Good, once you have done this you’ll need to go to your VAT settings (Reports > VAT Returns > VAT Settings) and make sure that MTD is ticked and that there is an account selected from the drop down next to HMRC account

Perfect thank you this worked.

1 Like