Payment options missing from invoice?

Hi Everyone

I’ve been setting up my quickfile account, and have run into a small issue. I’ve set up a payment integration with Stripe (‘Your Stripe account is linked to quickfile’), set up a test customer (with email address) and ensured that ‘Disable Payment Option for Stripe’ is deselected for the client.

When I create a test invoice, there’s no payment option displayed, no link to a client payment portal. I’ve tried ‘More Options’ > ‘Pay online’, switch is ‘On’.

I have a feeling I’ve missed something- would be grateful for a pointer in the right direction?


Hi @Charles_Andrews

Welcome to QuickFile!

Everything sounds as it should be there. Is it just one invoice you’re missing the button from, or are there others too? If there are others, is it just for a specific client, or are there more than one?

Hi Mathew

Thanks for replying. I’ve generated a few invoices for different pretend clients, and no payment option seems to be visible on any of them. I’ve just realised- I didn’t mention that I’m looking at the invoice preview, I haven’t tried sending a real one yet!


Thanks for the details. The invoice preview shouldn’t make a difference. As long as you’re going to More Options >> Pay Online, you should see all the options as you would expect.

It should appear similar to this:

Clicking “Continue” next to Stripe should then prompt for card details.

Just to come back to you on one of your earlier points:

The portal link will appear when the invoice is sent. Even if it’s “flagged as sent”, the link will then appear for you to access it. But it’s worth noting the link is unique to your client contacts, which does create an entry in the event log to show they viewed the invoice.

OK. I can get to the pay online page as per your picture, so I guess that it’s working as it should.

Thanks very much indeed for your help.

This topic was automatically closed after 7 days. New replies are no longer allowed.