Personalised SMTP stopped working, invoices out from again

my SMTP seems to have stopped working some time ago, and my invoiced now are coming from ending in recipient’s spam folders.
When I try to reconfigure my SMPT I get a timeout error. I am sure the settings are correct because I use the same ones for my email client, and I have double-checked them on (my email provider) website.

I have also added SPF record ( to my domain DNS just in case (domain managed by but it did not help. I still get the timeout error.

Can you please help?

You may want to open a ticket with your mail provider to see if they still have our IP range ( white-listed. This would normally be the reason why you’d suddenly encounter a timeout issue when there has been no change to the underlying credentials.


The SPF record won’t have any affect on the SMTP time-out, it will just add a record to your DNS that any recipient can lookup to tell them it’s OK for your mail to arrive from our servers.

I did a quick check on your mail server and it’s not responding at the moment:

Thank you, I will contact them. I have just sent a test email from this account from my email client and it worked without any problem, so I am not sure why mxtoolbox shows it not responding.

It’s possible that they’re just blocking these sorts of diagnostic tools, so perhaps not the most reliable indicator.

Please let me know what they come back with.

I have just opened the ticket, so I will keep you posted once I get a response. Thanks!

1 Like

Could be an encryption requirement?

This topic was automatically closed after 7 days. New replies are no longer allowed.