HOME / COMMUNITY Switch to knowledge base

Some emailed receipts not appearing in receipt hub


#1

For a long time I’ve had my home scanner set up for “scan to email” to send scans directly to the receipts@quickfile address, and this has worked fine up until now. This evening I sent a load of scans as normal, but I got bounce messsges from Gmail (apparently the target mail server for receipts@quickfile) saying it couldn’t authenticate messages from my address. Have you recently moved mail host or has it always been gmail and it’s just that google have recently chosen to tighten things up on their end?


Edit: fixing up the SPF record for my domain seems to have allowed gmail to accept the mails from the scanner, but they’ve not appeared in my receipt hub, I’ll check again in the morning.


#2

Hi @ian_roberts

Yes, we use Google for the mail server for the receipts inbox, although personally I was unaware that they had tightened their policy on this.

Out of curiosity, who do you use to provide your emails?


#3

So the messages my scanner sent last night still haven’t shown up in the receipt hub, but another PDF receipt I forwarded from my regular email program this morning has appeared. Does the receipt hub process messages that get delivered to the receipts@quickfile spam folder or just those that end up in the main inbox? I wouldn’t be surprised if Google has started deciding to spam-filter my scanner’s messages which are just a PDF attachment with no message body.

My email all routes through my own mail server, my domains all have the right MX records and all but one of them had the right SPF records up to yesterday night, I’ve since duplicated the SPF record for the last domain. My account number ends 63368 if you want to see for yourself which addresses I have configured.


#4

Thanks for the details @ian_roberts!

It is those that end up in the main inbox, although we do manually unblock emails from the spam box once every few days. I’ve just taken a look and found 4 emails in the spam box from one of your email addresses. I have now released these, so they should appear in your account shortly.

I have specifically reported these as “Not spam”, so hopefully that helps!


#5

Thanks, they’ve popped up in the hub now. Hopefully that’ll be enough to stop it happening again in future. Was there any indication on the gmail side of why they considered those particular messages as spam? Would it help if I changed say the attachment file name or the email subject line? I’ve been using exactly this setup with no trouble for over 3 years now so I guess it must be a change on the Google side somewhere.


#6

It did say that it looked like other spam emails, but that’s about it.

I did however check the original version of the email, and the SPF passed.

Keep an eye on it, and if you do encounter any problems in the future, let me know and I’ll check it out for you.


#7

Same again today by the look of it - the messages are getting through to the receipts@quickfile mailbox but not showing up in the receipt hub (presumably getting spam-filtered). I’ve changed my “scan to email” setup to use a more sensible subject line than just “scanned document” and to include a body as well as the PDF attachment in the email, but that doesn’t seem to have helped. I also worked out how to enable DKIM signing for the domain in question, but still gmail seems to be delivering all messages to spam.

In fact they seem to be sending all messages from my domains to spam. I have a feeling I may have to take it up with google rather than with you…


Edit: I’ve bypassed the problem from my end now - with a script on my mail server that intercepts messages from the scanner and pushes the PDFs to the Document_Upload API - so you can delete those messages that ended up in your spam, and I’ll keep going with google to try and get to the bottom of it.


#8

I found 3 emails caught in the spam filter which I’ve now released. I have also added your email address to our contact list, so hopefully Google will be a bit more trusting! :slight_smile:

Hopefully not, but I do feel that this may be the only way. This link may help in this case:

https://support.google.com/mail/contact/msgdelivery

I’m sorry! I released the emails before I read this far down!


#9

This topic was automatically closed after 7 days. New replies are no longer allowed.