Website load problems on Plusnet

Had trouble logging in today. Took about 15 mins for pages to load. Now i’m trying to create sales invoices and its taking ages for inventory items to load.

Not sure if there’s problems at my end or yours? Not having any issues with other sites/programs. Have tried on chrome & edge (yuk)


Hi @scoobeski

I’m not seeing any issues with my test account, and I’m not aware of any issues affecting the services.

Will keep an eye on it from our end in case anything crops up. Please keep us updated from your end too.

Typically if we are seeing timeouts, our own admin panel will light up with errors.

I’ve also pulled up the inventory list on your account and it’s loading in under 1 second. Are you able to check via a different internet connection, perhaps on mobile 4G?

I can log on pretty quick through mobile/4G. Guess it must be something my end then :-/

1 Like

Whereabouts in the country are you? What ISP are you using?

Everything on our side is running smooth but I’m wondering if there are any ISP related routing problems.

We’re in Nottingham and with Plusnet.

I think it’s sorted now. Cleared cache/history and restarted PC again and restarted router.

1 Like

OK thanks, glad to hear it’s working fine now.

There were a few reported connectivity problems this morning. But it’s something outside our data center… just trying to identify a common link.

1 Like

Took about 15 mins to log in again today. Tried doing restarts and cache clearing but that didn’t work this time. Also tried going to your main site and that took ages to load too.

@scoobeski - did you try loading the site on your mobile again when you were experiencing the issues? Just trying to get to the bottom of it all!

I forgot. If it happens again will check that.

Hi Glenn, I am still experiencing issues. I used your link to check the page above, and it connects perfectly. (http) I have a hunch that is something to do with the Https security, as that is when it seems to hang, the bottom tab says establishing a secure connection, but it mostly fails. I have logged on a couple of time this afternoon briefly, but then pages won’t load or refresh every time when I am logged in.

We have experienced difficulties in accessing our affinity accounts and lately we cannot login into the quickfile server. This is not due to our systems since we can login onto the internet and other cloud software without any issues.
SInce we are within very tight dealines as regards self-assessment this is increasing the stress our staff is experiencing with clients on Quickfile bookkeeping. Can you please either assist or resolve this issue please.

We have tried several browsers.

Thank you.

Hi @ElpisBS

We’re not currently aware of any issues, apart from one possibly isolated to a specific ISP, but this isn’t related to our servers.

What sort of issues are you receiving - timeouts, page not available, incorrect details etc.?

Time out is the problem with the timer running for ages. we are back in now but still experiencing delays. Thank you for looking into this though.

Everything is running smooth here, we have no error reports and we can see users regularly logging in.

We did however have some reports a couple of days ago from users of BT Plusnet that were experiencing timeouts. This eventually resolved itself.

Same problem here, had a few issues yesterday, with spinning wheels, and this afternoon just cannot get onto the server. My end is fine running a fibre connection, logs on to everything else in an instant. I am on plusnet fibre , Why would that be an issue?

Hi @axispara

There were some issues reported a few days ago with Plusnet and BT, but everything seems to be running fine at the moment.

This web site independently checks any site, and it’s also showing there’s no issues at the moment:

It has just allowed me back in and is working again (-: but it is frustrating, would be good to understand what the issue is

Glad to hear you’re back in. We’d also love to know the issue, but the only issues we seem to have reported at the moment are share one common factor, which is plus net.

Do you see any error messages when you try accessing the server?

I have just put a ticket in with plusnet to see if they know about it. The symptom is the page just hangs with a spinning wheel loading page, but gets no further. No error messages, timeouts, nothing