HOME / COMMUNITY Switch to knowledge base

Can’t return VAT

Software will not allow connection to HMRC. My Return is late thanks to QuickFile.

Hi @lewis,

I have just replied to your email ticket regarding this. I believe this issue should now be resolved.

Please let us know if you require any further assistance

Hmrc allow one month and 7 days to prepare and file a vat return.

Perhaps other users may have been able to help if you had ask within that time.

How do you delete a rolled back return so you can send the next correct saved one.

Hi @lewis

If you’ve submitted the VAT return to HMRC, rolling it back won’t undo this, only within QuickFile itself.

Are you on MTD? We can certainly provide some guidance on how to handle this within QuickFile if that helps?

Regarding your original post - were you seeing any errors? Did anything in our troubleshooting guide help?

I believe I was unable to send it as your software wasn’t allowing it. I then checked it and saw some sales had been left out I don’t know why. Maybe because they were not marked as paid. So I marked them as paid and they appeared n return.

So I need to get rid of the rolled back return and send the later saved one.


You sent me an email with unauthorised message.
I read everywhere, but your colleague Beth did something. Then she told me to rollback - I’m not sur what that does. But as I said in my last email the rolled back one is not right and my later saved one has the correct entries.

Were you seeing any error messages? Did anything in our troubleshooting guide help with this?

Are you enrolled for MTD (Making Tax Digital), and was the return submitted to HMRC successfully? If you’re unsure, any return submitted to HMRC has a submission reference at the top.

If the return has already been submitted to HMRC, you will either need to correct it with them, or depending on the value of the difference, wait until the next period. Within QuickFile you would only be able to correct the figures within your account itself.

There’s no number on the rolled back one.

Can I get rid of it and sen the newest ‘SAVED’ one?

There is nothing on the forum or knowledge base to help me and all this has been caused because your software didn’t allow any connection.

All my inputted figures were correct they did not get included because of the way your software works.

I am on MTD and I barely understand accounting, it is not at all simple to use. Can you help please.

Sounds more of a username and password issue than quickfile not doing what it should? I use mtd but I don’t need to enter any passwords or anything other than the initial setup so not sure where you would correct this

If there’s no number or reference, it’s unlikely it’s been submitted to HMRC, so you should be able to submit it this time around.

Roll back the saved one, but when you create it again, ensure that the option to file electronically to HMRC is selected:

If this isn’t ticked, it won’t be sent to HMRC, only saved.

Judging by the error message, as @Spike mentioned above, it sounds like a username and password issue (which is only relevant for non-MTD submissions), or a connection issue. If it was the latter, you wouldn’t have been able to get as far as the return on MTD, so I believe something is set up incorrectly on your account.

If you go to Reports >> HMRC, do you have an active connection there? If so, and there’s a green tick under “VAT”, and the “Status” column says “Good”, then you should be able to submit to HMRC without any issues.

First, roll back the saved return for the period so that period is available for filing. Then go to Reports >> VAT Returns, you should be able to select the period (with an “Open” label), and file it there.

As mentioned above, just ensure that the “Send electronically to HMRC” box is ticked.

If you don’t have an active connection in the HMRC section, you will need to connect your HMRC account first by clicking on “Connect +” and following the steps from there. You should then be able to submit the return as outlined above.

I hope that helps

I am conne ted to HMRC MTD service.

I have two rolled back reports for my vat period. One is correct one is wrong. How can I just send the correct one?

Hi @lewis,

You needed to roll back the return to unlock all of the transactions needed to submit the period to HMRC - I had noticed when helping you with your HMRC connection that you had a saved return for the same period that was due with HMRC.

Now that you have rolled it back you can now go to Reports >> HMRC and prepare the return to submit

I have no idea why the correct rolled back vat report was sent.

I still have 2no rolled back reports on the list, what will happen with them?

That was very stressful and the fact remains my VAT return was delayed, late and complicated by the lack of connection to HMRC.

I would appreciate an explanation of the lack of connection.

Thanks for all the help.

Regards Lewis

Regards Joy

Hi @lewis,

The rolled back returns weren’t sent anywhere, they were originally just saved on your account. You must have saved them when trying to submit them before your HMRC link was working again properly.

Saving and Rolling back returns in QuickFile doesn’t affect HMRC and all it does is lock and then unlock those transactions into a period. The rolled back returns will just stay in the background on your QuickFile account but will be hidden so no need to worry about these.

The issue you had with the link to HMRC was that you added a second link but hadn’t removed the initial out of date link so your VAT settings were still trying to access using this link. I removed the old expired link for you and updated your VAT settings to look at the new link.

It might be worth just double checking your VAT settings to make sure that everything else is in order before trying again.

Is there any reason for QuickFile to maintain these links once you have detected that they’ve expired? Maybe you could consider adding something in the workflow whereby if you try and use a link that fails then there’s an option to disconnect it immediately at that point rather than having to manually disconnect? Or maybe have it so that when you connect a new account for VAT purposes and there’s already an existing VAT-enabled connection present a pop-up message offering to disconnect the old link now (since from what I see in these forums there’s never a good reason to keep two VAT connections active at the same time on the same QuickFile account)?

I think what happens is that when people hit the 18 month expiry for their MTD access tokens, while technically what has to happen then is that you revoke the old token and create a brand new one, what it feels like to the user is that they’re somehow “renewing” the existing permission, and it doesn’t occur to normal users that they have to revoke or disconnect anything - “I don’t want to disconnect, I want to say it’s OK to stay connected”.

When a renewal is due there will be a specific option to renew the existing consent. If this button is clicked the tokens will simply be refreshed.

I suspect what’s happening is the user is clicking the blue “Connect” button which is then creating another duplicate consent. We’ve limited the number of consents recently to two to prevent duplication, we may need to reduce to only allow one or add another warning.

I would welcome some advice from Quickfile please.

I tried to file a VAT return yesterday. I managed to send my return to HMRC but then received a rejection email from Quickfile telling me that my return had not been submitted.

The message was “The VRN specified was not found…”? I have been registered for VAT since August 2013. HMRC says I am already registered for MTD.

Please help, I have now spent days on what I thought would be relatively simple process.



The fact you received a rejection email rather than it just failing immediately suggests to me that you’re configured for the older XML submission system rather than the newer MTD. In your QuickFile “reports -> HMRC” page you should have a tax account listed and in your VAT settings you should have both the “online filing” and “use MTD features” boxes ticked, and the tax account selected in the drop down box. If you haven’t ticked “use MTD” but you have filled in your gateway user ID and password instead, then that is the older non-MTD system.


Thank you. I followed you advice, however I am now getting a message:

“HMRC have indicated that no data could be retrieved for this VRN…”

Further advice and guidance would be most welcome.