HOME / COMMUNITY Switch to knowledge base

Filing First VAT Return

Can you please help me with my first VAT return, I have posted several times on this site and the guidance has helped me to sense check my return by I am still not able to submit and my submission date is 7/2/21. I thought I had made headway when I called HMRC and they advised that my VAT account was blocked because I needed to confirm my address. I have done this but am still unable to link my tax account. When hovering above the filing status button I get error “NOT_FOUND…The remote endpoint has…” Urgent assistance would be most welcome.

Hi @Matt2,

Have you signed up to MTD and had the confirmation email? Have you linked the correct government gateway account?

It may be worth going through the troubelshooter to see if that helps: Making Tax Digital: Troubleshooting

Yes I have and there is a note on the HMRC site saying that I have signed up for MTD when I log on to my VAT account. Yes, the correct Gateway account is linked.

Hi @Matt2,

Did you work through the troubleshooter? - are your vat settings all correct?

Beth yes I did work through the troubleshooter and HMRC says I am set up. Any further suggestions please. My deadline is 7 Feb 21 is there a helpline number I can call please?


Hi @Matt2 ,

We don’t offer telephone support i’m afraid, but would you mind checking your VAT settings within QuickFile Reports > VAT Returns then click the VAT settings button.

You need to make sure that the enable online filing is ticked:

and also that the MTD features is ticked

The username and password settings don’t need to be filled in as these relate to the old filing method which I believe is where the error is coming from


Thank you. I have followed your advice.

I spoke to HMRC today and they think the problem could have been caused by a queried address. I have now changes the business address. Fingers crossed!

Thank you for your help.

Hi @Matt2

Hopefully this has sorted the problem for you, but if you have any further questions, please don’t hesitate to get back in touch.

This topic was automatically closed after 7 days. New replies are no longer allowed.