HOME / COMMUNITY Switch to knowledge base

MTD for VAT connection issue

I have an Affinity account and am getting the following message when I create a VAT return for one of my clients:

“You are not yet authorised to view this report for the VRN XXX . Please ensure your VAT number is correct and you have connected the corresponding HMRC Tax Account. If you have recently enrolled on the MTD scheme please allow 24 hours for HMRC systems to update.”

I have other MTD clients on QF and can connect to HMRC without any issues. I have called HMRC about this particular case/client and my practice is still authorised for MTD (I’ve been using MTD & QF for nearly 2 years with this client without any issues). HMRC cannot find any block or reason why any software would not be able to connect to HMRC?

Any ideas?

I’m getting the same for my return:

You are not yet authorised to view this report for the VRN xxxxx . Please ensure your VAT number is correct and you have connected the corresponding HMRC Tax Account. If you have recently enrolled on the MTD scheme please allow 24 hours for HMRC systems to update.

Also this when I try and re-register via the email link:

A maximum of 2 connected tax accounts is permitted, please remove an account before adding a new one.

Type Name Connected Status VAT Link Disconnect View
xxxxxxx LTD

Client not Authorised

The account you have linked to QuickFile is not authorised to access or file VAT information for the VAT registration xxxxxxxx. This error usually occurs due to one of the following reasons:

  • The wrong account has been linked (e.g. a personal tax account rather than the organisation’s tax account)
  • The VAT registration number has not been correctly entered.
  • The organisation is not fully enrolled for Making Tax Digital (MTD)

You can find more information in our HMRC troubleshooting guide here|

welcome any advice.

It’s possible the vat link has expired which is does after 18 months. Disconnect the vat link and then go through the authorisation process again.

Disconnect and remove any duplicate vat links before trying to reconnect.

@Paul_Courtier You star, that worked! Thank you.

Worked for me too, many thanks.

Seems to be the answer to my issue also. IS someone able to describe how I disconnect and then reconnect the link. I’m not even certain if this happens in Quickfile or on HMRC site.
Many thanks in advance,
C

Go to Reports > HMRC > View and then you should see a disconnect option. Then you can re-connect.

This topic was automatically closed after 7 days. New replies are no longer allowed.