RBS Automated Bank Feed problem

Hi all,

I just took out the automated bank feed subscription to get my RBS bank account(s) automatically updated.

However, I can’t get it to pass the verification stage; it always comes back with complaining about “Multiple Logins” (Error 416) - see screenshots.

The only places I use to access my bank account online are (a) my browser (usually Chrome), and (b) the RBS app on my phone. I know the credentials are correct as I have no issues logging in using my browser - and that one doesn’t complain about multiple logins…

Help, please?

… and right after posting this question, it worked!?

Weird - perhaps me threatening after 30 minutes trying unsuccessfully with taking action might have scared it :wink:


It seems that the integration doesn’t support automated feeds for RBS (business) credit cards? Can’t find that information anywhere, and without that, automation is only halfway and the automated feed subscription of not much use…

Any info?


Hello @Michel

Some banks only permit you to be logged in from one place at a time, so if you’re active (or recently active) in the app or on their online banking, it may prevent you from logging in as you’re “already active”. That said, the usual behaviour I’ve seen elsewhere is it would log out any existing sessions for the feed to run - this certainly goes against that, but this would be down to the individual bank.

Regarding the credit card query - if it’s available on your online banking login in the same manner as your current account (e.g. it appears on the same overview page and then in the same format for transactions), it would normally be available. That said, this is down to Yodlee and how they support it rather than the way we update your account.

The full list of supported banks can be found here. I’m not familiar with the RBS set up, but if you could provide me with a few more details in terms of accessing it, I can certainly raise this with Yodlee and see if they can advise further.

Hi Matthew,

thanks for the answer - I know with reasonable certainty that I wasn’t logged in anymore. However, since automatic feeds are working, there is no need to log n anymore (except for some odd settings stuff, or manual payments).

Regarding RBS credit cards. Oddly enough, even though I am a commercial customer, my bank account banking seem to be going through the personal banking system (as far as Yodlee tells me), while the credit card seem to go through their business banking portals - this might be because at the time I set up my business banking accounts, RBS seemed to have mixed up intentions and created a personal savings account (rather a business savings account)…

In any case, the access method for both debit and credit cards are - for me - the same, i.e. the customer number, PIN, and online password, of which RBS will request randomly three numbers (PIN) or characters (online password).

I am not so sure about the capabilities of the RBS credit card system’s account export - it appears to me rather ancient and manual in the entire user interface, and geared towards larger corporate setups where you have a corporate account with several linked credit cards: The corporate account sees all the CC balances only (and to which extent they are settled), whereas the individual cards see all the transactions on that card.

In practice, to download the individual transactions per card, I need to:

  • Select the “account” (corporate or individual card)
  • Select the period I am interested in
  • Export the period’s transactions in a variety of formats (MS Money, Quicken, CSV, etc)

To see the settlements of the CC debts, I need to:

  • Select the corporate account in the same to-left menu bar drop-down
  • Select the period I am interested in
  • Export the settlement payments of my CC

Essentially, the RBS UI treats each CC as a merchant account.

Does that help?

Thanks @Michel - much appreciated!

I’ve had a quick look through the list of banks being used by other users, and one that stood out to me was Royal Bank of Scotland (Cards Online), and on closer inspection Yodlee actually lists a few alternatives:


I can’t say for certain if any of these could be of any use, but it does appear that Yodlee have separated them, probably because of the differences in the interface meaning they need to be processed differently.

When you try to connect a feed, if you select the option to connect a different bank and search for “Royal Bank of Scotland”, you should see the list above.

Let me know if that works for you?


Of course - me lazy git didn’t find it in the “most popular” list…

I could connect successfully, and Yodlee presented me with a selection of two accounts to pick one from. So I picked one, and it connected successfully.

But then I realised it was the wrong one, i.e. the one that records all the balancing transactions against the CC (the “corporate account” I referred to in my previous replies), which I don’t need because I have them in my current account feed.

Instead, I need the one for the individual CC. Unfortunately, I can’t select that one anymore even though I disconnected the bank feed! I then tried to “connect another bank”, but now I get the warning in the attached screenshot…

Some component in the system doesn’t let me choose the correct account. Or I am entirely blind, which I certainly wouldn’t dismiss… :slight_smile:

Hi @Michel

That certainly doesn’t look right - especially if you had one to disconnect in the first place.

If the same thing is still happening this morning, please let me know and we’ll open a private message so we can take a closer look at this for you.

Hi @QFMathew,

It is still the same way - although to confirm it indeed imports transactions, it was still connected to the “Corporate CC account” (which I effectively don’t need).

Should I disconnect and wait another night and try again?

If you could disconnect it, you should be able to connect a different account straight away. Although please let me know if this isn’t the case?

It is currently disconnected:

However, when trying to connect it, I see only one account, where there should be two:

The other one I saw very, very briefly at the beginning of the process when I connected for the first time. Never again since…

Hi @QFMathew,

Any news on this, please?


Let me send you a private message and get a few more details and I’ll pass this over to Yodlee to investigate. It should all show OK if it’s there in your online banking account.

Please look for a green notification in the top right corner.


Thanks - response is on its way.


Hi @QFMathew,

It’s been a while, but now I cannot conenct my RBS credit card for automatic feeds at all anymore?

It’s confusing…


Hi @Michel

Are you seeing any error messages? How far in the connection process can you go with this?

Hi Mathew,

I see RBS as the provider for my current accounts, but nothing in regard of the CC.

In the end, I realise I only rarely use my CC these days (do everything through debit) so it is for me not so much of an issue.

But it might be for others.


The available bank list will only be what RBS sends us. This is a live list, so providing it’s been authorised, it should show in the list.

If you do have a chance to try it again, please ensure the card is authorised during the authorisation process, and hopefully that should show on QuickFile then.