Accounting for Card Processing/Transaction fees

Hi, I’ve recently started taking payments from Square. These transactions are credited to my bank account net of the transaction fee (either 1.75% or 2.25%). Due to the difference in invoice total and the payment received in my bank account (Credit from Square) Quickfile fails to recognise these as matching. Is there a way around this? I’ve tried to ‘Tag’ the payments to the invoices but that only seems to result in a partial payment.


Basically, the “payment from a customer” is when you take the payment, not when Square send you the money, so you have to have a bank account that represents money you’ve taken via Square but not yet been sent. Payments from your customers come in to that account in full, settlement payments are transfers to your current account, and the fees are handled separately.

1 Like

Doesn’t the Square integration create a merchant account like the Stripe and GoCardless integrations?

Yes the new Square integration does create a holding account for you and then automatically pulls in all transactions overnight. That said the Square integration is invite only at the moment, @RichardCCH if you want us to activate that on your account please let me know?

More info here:

Square Payment Option and Data Feed

1 Like

Hi @Glenn , I’m already on the trial … maybe should have mentioned that :slight_smile:

1 Like

Ah ok, in that case in “Account Settings” >> “Manage payment options”, you should have the holding account setup as follows:

This means that the gross invoice amounts should be deposited into that holding account, not directly into your current account. You can then match your invoices to those amounts in the holding account.

Then when Square payout your lump sum of sales (less the transaction charges), you would tag that as a transfer from the Square holding account into your current account. The idea is that this then offsets the sales and transactions charges and the Square holding account balance trends back to zero.

Thanks @Glenn, I’ll give that a go…

This topic was automatically closed after 7 days. New replies are no longer allowed.