Adding Revolut USD account to Live Feed


I have linked Revolut GBP account to Quickfile, but cannot link the Revolut USD account because it does not have a sort code and an account number, only IBAN. How do I link it? I have to link it, because there are currently sums being received in the USD Revolut account, which are not reflected anywhere.


Hi @Kazik

There’s no requirement for the sort code and/or account number for you to link accounts. Providing authorisation was granted when you linked Revolut to QuickFile, you should be able to link them up within your account.

If the account isn’t showing, you’ll need to revoke the feed (Banking > Open Banking Feeds), and then re-grant access to Revolut. It should prompt you to select which accounts you wish to give access to, which would then enable you to link them within QuickFile

Hope this helps.

Thanks, but does revoking and regranting access mean that all my current transactions (and attached receipts etc) in the Bank Account section will disappear?

Not at all. All the transactions that have already been imported into QuickFile will remain. You’re just breaking the link between QuickFile and Revolut, so no new transactions will import until the link is re-added.

Any problems, just let us know :slight_smile:

Screenshot 2022-01-17 at 09.44.34

As you can see from the above, it does not allow me to link the USD account. Any suggestions?

Do you have a USD and EUR account set up on your QuickFile account, that’s also set up as “Revolut”? For example, if you do have the account set up already, if you view it, do you see the Revolut logo on the page, or more of a generic bank icon?

First you have to enable your quickfile account for multi currencies. Then you have to select all currencies you want to have on your quickfile account.
After that, create a revolt bank account for every currency you have with revolt and want to link with quickfile.
After that establish your link and choose all the accounts on revolt which you want to link to quickfile. After the link is setup connect every currency bank account within quickfile to the right currency account in your live feed.

Hope that helps

Thanks. I see the Revolut icon. I cannot see the USD and EUR accounts either under the icon or as separate accounts. Both USD and EUR are ticked under the multi-currency settings and were ticked all along. I am not sure what else to do…

When I try to set up live feed, Quickfile says (as you can see in the previous screenshot) - No qualifying USD account found.

Can anyone help with this? Without this option, Quickfile becomes non-functional for me…

The solutions proposed so far do not work.

@Kazik I’m using Revolut (Business) and have feeds apparently set up OK for GBP, EUR and USD accounts. I say “apparently” because there have been no transactions yet in the EUR or USD accounts so I don’t yet know if they are working, but they are at least showing OK.


I don’t remember exactly what steps I took to set it up, but I recall that it was really easy.

As @QFMathew says, are you sure you’ve actually enabled the EUR and USD accounts in Revolut itself? See here.

Thanks all. I have now managed to add two Revolut accounts - GBP and USD. However, for some reason when I try to add the Revolut EUR account it says that the account already exists and asks me to enter a unique account number.I have used the same account details for the GBP and USD accounts and that worked fine, but for EUR, being the third account, it does not seem to work in the same way for some reason. Any ideas?

You don’t have to enter an account number when setting up the bank in QuickFile, that’s just something for your own reference. All that matters if you want to link a feed is that the QuickFile bank account is set up with the correct bank name for your banking provider, the sort code and account number are optional.

This topic was automatically closed after 6 days. New replies are no longer allowed.