Bank Feed Settings Bar not showing for Natwest


I am using Natwest as a bank provider and have never really got the QF integration working.

At one point in time the QF bar did appear and I did enter the generated key, after this the import failed telling me there was an issue with the key.

After this point however the QF toolbar no longer appears.
The QF button appears in the top right corner and goes to the NatWest site as expected.
At no point from then does the QF bar show.

The QF plug in is the latest V1.34
Chrome is Version 39.0.2171.95
OS W8.1 Fully updated
I have turned AdBlocker off.
Chrome Pop Ups are off.

Not sure this is a QF or NatWest issue, feels like Chrome or something is blocking the pop up?

Any thoughts appreciated.


Perhaps related?

Hi Glenn,

Yes i did a search of the KB first and did see this but my URL has not changed AFAIK.
It is still:


If I go to I see the banner at the top:

Is this not appearing for you? Have you got any ad-blocking extensions installed on your browser or any other extensions that may be interfering.

When you click the extension icon can you navigate to any of the other banks and see the banner?


I have turned off the Chrome pop up blocker.
I have now disabled AdBlock.
I have disabled HootSuite.
I only have QF and LastPass running.
The QF toolbar was still missing.

I then tried the other banks and I could see the QF toolbar on all of them apart from the NatWest account.
I then cleared all the cached settings in Chrome and then the QF toolbar appeared for the NatWest domain albeit empty.

I will go through the process of adding in the details again and let you know how it goes.


It could be that NW were caching your customer number and fast tracking you past the first screen? Clearing the cookies would explain why it then started working.

Unfortunately it was short lived.

I entered all of the details again and saved them.
The system appeared to auto login, assume this was QF and then the QF toolbar disappeared.
I tried to export some transactions and got the same QF message about an incorrect ID value.
Closed down Chrome, connected back to NatWest from the QF button and the QF toolbar has gone again.

Is there any way to force the toolbar to display itself?


Make sure not to check this box as it will skip the first screen and hide the settings panel.

Unfortunately I can’t test this at the moment as our Natwest test account expired and we need to reset the online access.


I’ve checked the logs and there’s a few users importing feeds from NW today.

Hi Glenn,

That was the issue, I cleared the cache again, reset all the values, logged in without setting that value manually (habit) and have been able to export a transaction.

Thanks for all your help.


1 Like

Hi there,
I am trying to import transactions from Natwest and same issues. I do see the floating Quick file on Natwest site and then as soon as I login in Natwest everything goes away. I don’t see anything being imported to QF though I specified the import from date in the floating bar and filled the details such as QR account number, id etc.
Many thanks for your help.

Hi Solar,

Try clearing your browser cache so that you have enter all of the QF details again, but just make sure you do not tick the box in Glenns screenshot in the posting from Jan 6th.
After entering your details in the QF tool bar this then allows the QF tool bar to be displayed and that will log you in rather than the NW site trying to do it for you, this was certainly my issue anyway.


Thanks David. It did work, however it said that only 2 months of transactions can be imported?

The settings bar should only appear on the initial login page and will not appear if you’ve got Natwest pre-saving your customer ID. Which is why clearing your cache works. Also once you’ve logged in it should disappear.

I’m not sure about the 2 month limit but this is more likely to be a restriction with Natwest on how far back the export goes.