Carriage 5100 bug?

Looking at my profit and loss report I noticed that the carriage account was only showing £12.60 looking further, all my purchases with a carriage charge that had correctly been categorised to the 5100 carriage account had for some reason changed to “General Purchase”?

I have now been through all my purchases and changed these back to the correct category, strange why this would do this? maybe something you should take a look at.


Hi @Rob, I have asked the development team to investigate.

How did you originally tag these entries? Can you produce an example invoice?

Looking at invoice #QF00083 you have several lines with one marked as “Carriage”, I see this is one you’ve recently corrected.

I had a look at the log and that line was originally saved as “General Purchase”. It’s possible you had the focus on the category dropdown and scrolled down the page, but instead changed the select option.

I’ve recreated new purchases similar to yours (i.e. one carriage line) without any problems.

I could accept this on one or two entries, but 50!

Also the carriage entry is jumping up the listing, I always enter the carriage on ,the last line but for some reason they are jumping around?

I will monitor this over the next few purchases I enter


When you’re keying in your invoice, at what point are you selecting the supplier? One thing that springs to mind here is when you select a supplier it will change the drop-down category selection to whatever that supplier default is set to.

If you select the supplier before keying in the lines you’ll be fine, but if you select the supplier last it will update the categories on the page to match the supplier default.

I just saved the following invoice and it came out as expected and in the order specified.

Hi Glenn

thank you for your reply, I always select the supplier first, I will monitor this and try to replicate what is happening.




I have just entered a purchase and saved successfully with the carriage on the bottom line, when I then go back into purchases and view the invoice I have just created the carriage category has changed to General purchases!

Once I go back into it and change it back, re-save, it appears to save it correctly.

Definitely a bug



We’ve not changed the purchase entry screen for quite some time and I haven’t seen any other reports of this, which I would expect to if it was just defaulting everything to “General Purchases”.

I doubt it’s anything specific to the code 5100. I did notice you’re using IE 11 and I’ve been trying to replicate in Chrome. Let me test again in IE.


Tried in IE11 but couldn’t replicate. Here’s how I’m entering the invoice:

Hi Glenn

It appears fine on the initial save, it is only when I go back in via the main purchase page, I have not tried the link as per your example.

I will create my next invoice in Chrome to test browser.

Many thanks


Sure, let me know how you get on.

This topic was automatically closed after 6 days. New replies are no longer allowed.