HOME / COMMUNITY Switch to knowledge base

Co-operative Bank Statement Problem

Have imported Co-op bank CSV file of transactions. In Quickfile the debits show up in the “money in” column and the credits aren’t showing at all.
Column order in the CSV file is: Date/Description/Type/Money In/Money Out/Balance.
Definitely selected “The Co-operative Bank” in the drop down bank selection menu.
Looking at previous posts, looks like this has been a problem before but not sure if it’s been resolved by Quickfile.

Hi @KarenS

We did update the format of these files within the last few weeks following previous posts.

I will just check on the format we expect this to be in, and perhaps you can compare it with the format of your file. Bear with me.


Edit
The format we expect the CSV file to be in is as follows:

  • Date
  • Bank Reference
  • Transaction Description
  • Customer Reference
  • Amount (both money in and money out)
  • Running balance

Does this match what you’re seeing in your CSV files?

Hi Matthew
Here’s the CSV file columns, with a couple of transactions so you can see it in action::

Date Description Type Money In Money Out Balance
2021-05-04 MARK UNDERHILL CREDIT 93.5
930.28
2021-05-04 KAREN SIMMONDSFD BP/SO
300 836.78

Thanks for getting on to this so promptly!
Karen

Thanks @KarenS - that’s helpful!

@Joy @jwf - I’m aware that both of you have used the co-op statement upload in the past, and I believe one of you supplied the new format that we updated to recently. Does yours look like @KarenS’s example?

No, not sure where that format is coming from. Will have a quick look after lunch. Also, can’t really tell what KarenS has for sure because she needs to show us the file as text. Most likely there is somewhere else on the Co-op interface where you can get another csv format of transactions.

Maybe KarenS can describe what method she is going through on the Co-op interface to obtain the csv she has.

Hi @KarenS

Following @jwf’s post above, are you able to provide a few steps to download the CSV file from the Co-op, please?

You’re welcome to upload a CSV file if you wish, but please remove any sensitive or confidential data before doing so as this is a public forum.

For Co-op Business Online Banking from desktop browser, this is what I have been doing:

  1. Log in
  2. In the ‘Account summary’ box, next to the account balance, click on ‘Actions’ > ‘View transaction history’.
  3. Click ‘Search Transactions’ and set the from and to dates. Then click the green ‘Search’.
  4. At the bottom of the screen is the ‘Download Details As’ option. Change PDF to CSV. Click Ok.
  5. Select the file path and input the filename to save as.

I can only guess but perhaps KarenS is using the mobile version of the Co-op interface?

1 Like

Hello
The steps are: Transactions, select Date Range, click on Download CSV. (Screengrab at the bottom of this email).

I couldn’t see another option for a CSV file.

I won’t upload the CSV file at the moment but when I open the file this is what I see:

Date Description Type Money In Money Out Balance
2021-05-04 MARK UNDERHILL CREDIT 93.5
930.28
2021-05-04 KAREN FD BP/SO
300 836.78

Thanks.

I am not sure but I think KarenS is using a ‘Personal Banking’ account and not a ‘Business Banking’ account. I think that may be the difference.

Yes, just had a look. The Co-op Personal Banking interface is very different to the Co-op Business Banking interface.

Co-op Business currently uses https://digital-business.co-operativebank.co.uk
Co-op Personal currently uses https://bank.co-operativebank.co.uk

Hello


I’m using the desktop version of the Co-op site, for a personal, not business account. The only difference to the steps you describe is that there’s no option to change from a pdf to a CSV.
I’ve always downloaded a CSV file from a personal account (my business is very small), so the problem is new since I last downloaded on 5 April 2021. I’ve just checked an older CSV file and the columns are in the same order as the CSV I downloaded today, so to me it looks as though it’s in the same format.

Best wishes
Karen

Hi @KarenS

We support the business CSV layout rather than the personal.

You can however use “Other” as the bank type and manually map the columns, rather than relying on what we’ve set it to.

Great. So Co-op changed the csv format for the Business Account but not the Personal Account.

Karen, the interface for the business account is very different from the personal account. So I guess the solution, if possible, is for QF support to create an upload option for ‘Co-op personal’ which is the old format, and an option for ‘Co-op business’ which is the new format. What a pain.

Thank you for the solution, will give it a go!

Karen

1 Like

At least the mystery is solved.
And QF have suggested a work around (use Other in the bank selection and map the columns), so I think we’re good!
Thanks for your help.

Karen

To explain how I have got it to work
I do the transaction search on the bank site, it then comes up with the last of transactions, at the bottom of that page there is a drop down box giving various download options ie PDF / CSV / BA12 /OFX /QFX/ TXT / XLS

I use CSV

when I upload the csv file I no longer choose Coop bank instead choosing "other "

I then get this message
Below is an extract of your CSV file. Please indicate where each field should be mapped to?

So …because when I upload I need to see who sent the payment to allow me to tag it to an invoice I map the description column to column 5 then it works, as that shows in the quick file bank page

( I think something else changed recently because until a few weeks ago this was column 4 !)

Its such a nuisance as until Coop changed last year it worked fine and despite them receiving loads of complaints they have not improved it

Of those download options given above Matthew… is there any other option I could choose that would work better ??
Joy

ah I use the business account