HOME / COMMUNITY Switch to knowledge base

Create Recurring Invoice via API ticks 'Auto Reverse Vat'

Well I managed to untick it, but it would be useful to prevent it getting there in the first place since nether we, or our members are registered for VAT.

As always, all advice would be greatly appreciated.

Mike

You could explicitly set ecVatExempt:false but I’m surprised if this isn’t the default anyway. Unless it’s something to do with the settings of that particular client?

The section of code that creates the client details is

        $request['payload']['Body']['ClientDetails'] = [
            'CompanyName' => $clientDetails['CompanyName'],
            'AccountReference' => $clientDetails['AccountReference'],
            'AddressLine1' => $clientDetails['AddressLine1'],
            'AddressLine2' => $clientDetails['AddressLine2'],
            'AddressLine3' => $clientDetails['AddressLine3'],
            'Town' => $clientDetails['Town'],
            'Postcode' => $clientDetails['Postcode'],
            'VatNumber' => '',
            'VatExempt' => 'true'
        ];

From what you say, it would appear that setting this to ‘false’ is the correct course of action. Before we used the API, we did not set any VAT settings.

Very many thanks for your feedback .

I was talking about an option on the Invoice_Create call rather than the client creation one, but I guess it’s possible that the default may be affected by the client level “exempt” setting. Which you shouldn’t set anyway unless you’re actually making supplies to that client that are exempt from VAT. Sales you make that would be standard or zero rated if you were VAT registered are still considered “taxable supplies” - you don’t charge VAT if you’re not registered but it doesn’t change the nature of what you’re supplying.

We have not changed the Invoice_Create API which has not given rise to this. Alos, our Invoice_Create calls are totally silent on the matter of VAT which does not apply to us.

What we have implemeted is the Create_Client API call, and I suspect that setting the VAT status might be something to do with this.

Mike

This topic was automatically closed after 4 days. New replies are no longer allowed.