HOME / COMMUNITY Switch to knowledge base

Customer and Supplier Turnover Reports - Net of VAT


Hi there,

I’ve been using your Customer and Supplier Turnover Reports (Are you planning to create a report of Customers sorted by Turnover?) and there are a couple of issues

  1. UI - there a bugs in the ‘Select All’ checkbox at the top of the list view. It sometimes works as expected, sometimes does not. Please could you test and fix.

  2. UI - it’s impossible to download every supplier if the list run across multiple pages. It’s annoying having to do multiple downloads and glue them together.

  3. VAT - the supplier turnover is shown gross of VAT. This is unusual and not as useful as a report that shows net turnover. Could you add a column that shows net turnover in the selected timeframe?




Another issue is that the ‘from XX to YY’ timeframe setting doesn’t work. The balances shown are for all time.


Hi @jamespbmatt2

Thank you for your post.

  1. Are you able to elaborate on the issues you’re experiencing please? E.g. what are you doing and expecting vs. what’s happening?

  2. This is by design. The lists are limited to 50 items per page to preserve resources. The work around to this would be to download an account backup. While this would give you a complete backup of your account, the file is a .csv so you could filter the data in software such as Excel.

  3. In the top right hand corner there’s an option to toggle what columns are shown which includes a net and VAT column. Although the totals aren’t shown, this can hopefully give you a better overview.

We’re certainly open to suggestions however. If you do have any suggestions, you’re welcome to start a #feature request (one per topic) and we’ll take a look into the feasibility of them if there’s enough interest.

I hope that helps!


Hi Quickfile,

  1. To recreate the error:

Purchases > View Suppliers
Advanced Search [Check box ‘Total Invoiced’], [Enter Date Range]

Ok so far. Results as expected.

[Check the box next to Supplier Name heading to select all] Results as expected
[Deselect select all check box] Results as expected
[Select select all checkbox] Nothing selected. BUG 1

[Click Export Data] Error message says that nothing has been selected. You have to manually select the suppliers.

  1. The auditors want a list of our biggest suppliers. This means downloading the full list of suppliers. It is a bad user experience to have to download as many reports as you have pages of results and then glue them together in Excel.

  2. There is no net versus gross toggle in the view I am looking at. Gross of VAT is almost irrelevant to most accountants as you can claim it back. To answer the question from the auditors I would have to sort through US, EU and UK suppliers, work out which ones are charging UK VAT and then make some sort of manual adjustment. Bad user experience.

These are not features they are bugs. Could you let us know when they will be fixed?



Thanks! I’ve replicated this and have logged it with our development team for review.

This isn’t something that’s likely to change at the moment. As I mentioned above, the limit of 50 to a page is put in place to preserve resources.

My colleague explains it better in several threads on the forums, including this one.

Apologies - that’s my error. There isn’t a net/gross column toggle on the supplier list, only on the invoice list. I will however raise this with our team on Monday and come back to you on this one.

I wasn’t able to replicate this one unfortunately. I have a supplier with invoices in December 2017 and in February 2018. I tried a search from 01/01/2018 to 10/03/2018, and this worked as expected. If you could supply a few more details, I’ll happily look into this further for you.


We’ll implement an update on Monday to handle this, it’s a fairly trivial fix.


Hi James,

It is now possible to output your supplier turnover NET of VAT.

The above update has been made to both the supplier and client overview screens.

We’ve also fixed the issue with the “check all” routine on the supplier index page.


This topic was automatically closed after 7 days. New replies are no longer allowed.