Deleting a VAT File

I want to delete a VAT return I seem to have created for 20C4. I am not being given the “rollback” option when I view the 20C4 return. It hasn’t been submitted to HMRC. Please advise how I can delete this 20C4 file.

Which route are you taking to get to the return?

If you go to Reports -> VAT Returns then that should list all your submitted returns, each return on that page has a “view” link at the right, and that link takes you to the page that should offer the “roll back” option at the bottom. If the return you’re looking for isn’t listed on there then it hasn’t been saved or submitted and there’s nothing to delete.

If you’re looking at the VAT obligations list (either via Reports -> HMRC, or by pressing the “create” button on Reports -> VAT Returns) then that offers “prepare” for quarters you haven’t yet submitted or “view” for quarters you have submitted. But the “view” option from this list is just a view of what HMRC have recorded as your submission, it isn’t the QuickFile record of the VAT return so there’s no rollback option on this view.

Many thanks for this Ian
I haven’t submitted the file to HMRC however I have 2 x created files and when I hit prepare for both the 20C3 and 20C4 I see the same figures which are correct for 20C3 return.
When I try to send the 20C3 file for HMRC it is coming up with Error Code 401. I’ve disconect and re-connected a number of times but still wont send the file saying status missing credentials ?
I’ve tried everything I can see in your help but can’t get the file away to HMRC. Any ideas ?

Hi Ian

I sent you a reply earlier re the Quick File system – didn’t realise you would be replying via email also :blush:

Here is what at see re the 20C3 submission I’m trying to send to HMRC


Kind regards for now


(Mobile 07711 885142)

Hi @Ivan1

The community forum is set up so any notifications you have enabled come through by email. As you’ve discovered, you can reply to these and they appear on the forum too.

It looks like the connection to HMRC didn’t successfully complete. You will need to disconnect the link between QuickFile and HMRC, and reconnect them.

If you go to Reports >> HMRC, you can select the account and then disconnect it. You can then relink the account from the same page.

HI Matthew
Many thanks for your advices.
I’ve disconnected and reconnected about 12 times now and the same 401 error message keeps coming up.
Any other ideas ?
Kind regards for now

Hi @Ivan1,

Have you double checked that you have actually disconnected the account?

If you go to Reports >> HMRC do you see any linked accounts here? If you see more than one you will need to view each link and disconnect leaving the most recent

Hi Beth. Can I send you a copy paste of what I’m seeing

Hi @Ivan1,

Of course, but please remove any sensitive information as this is a public forum :slight_smile:

You are welcome to send a private message to @QFSupport if you prefer?

Beth you are brilliant. Now sorted. Until you last text it had not been clear to me that I had to remove all the filed I had created in my attempts to disconnect and reconnect - there were about 15 of them. Your email prompted me to hit “prepare” on each and then “disconnect” for each one and one by one they were removed and then I make sure i had the link set up with HMRC, created a new report which has now been sent successfully. Thank you so much Beth.
Will I have to go through this process next quarter again, or is it every 18 months or never again ?
Kind regards for now

1 Like

Hi @Ivan1,

Glad to hear its all sorted, I believe you need to refresh your log in with HMRC every 18 months. So you shouldn’t need to do this again until 2022!

Thank goodness ! Have a great day Beth :))

This topic was automatically closed after 7 days. New replies are no longer allowed.