Email help - spf record include for quickfile

More than a negligible number of customers are claiming they are not getting QF generated invoice emails and we sometimes see replies where suspected dodginess has been detected by the customer’s email server. I suspected spf record in our domain to be insufficient. Sure enough, we did not have quickfile included. I cannot find what to “include:” for quickfile. I have tried as per old posts here but mx toolbox spf checker reports:

“A null DNS lookup was found for include (”

Can someone tell me what best to put after include:? Can I just use “”?

We use our own domain to send emails, a gmail address and quickfile so the spf record needs to cover all these.

Hi @jwf

Can I just double check that you’re using your own SMTP server to send the emails from within QuickFile?

Yes we are. Does that mean quickfile does not need to be added?

That’s right. Any emails would be sent from your own domain name, using your own mail server. As long as that mail server is specified, it should be fine.

It may be worth adding a dummy contact to one of your clients using a mail tester email address (, and then sending an invoice or similar to that address and seeing what the results are.

1 Like

Thanks, Mathew. When we CC ourselves when sending an invoice, for example, the From address is So does this CC not go through our smtp but the one sent to the customer does?

All CC’d invoices are sent through the standard QuickFile setup and don’t take into account the SMTP settings.

If you wanted to check (just to be sure), if you have a Power User Subscription, you can go to Account Settings >> All Settings >> Send Email Log (under the “Audit” tab), you can view the sent emails related to your account. At the top of each email, we show what SMTP server was used.

Hope that helps!

1 Like

That’s great, Mathew. Thank you for the quick replies. Also thanks for that mail-tester site. Very useful.

Edit: The Send Email Log is under Audit on ours.

1 Like

This topic was automatically closed after 7 days. New replies are no longer allowed.