Emailed invoices rejected for no reverse DNS

Hi Firstly, thank you for such a great system, I have used it for a few years now. It s brilliant.
However, I cannot seem to send email invoice to my clients. they are coming back with the following message. Please can you help.
Many thanks and kind regards

Your message did not reach some or all of the intended recipients.

Sent: 25 Oct 2016 07:35:35 +0100
Subject: New Invoice Created (Bob)

The following recipient(s) could not be reached:

Error Type: SMTP
Remote server ( issued an error.
hMailServer sent: RCPT TO:<info@*******.org>
Remote server replied: 550-5.5.1 Your server IP address [...] is missing a reverse DNS entry.
550-See for more
550-information. Protection provided by MagicSpam 2.1-5.3


Hi @Mark_Woodward

Thank you for your positive words!

The issue possibly relates to an issue linked with the mail setup on your account. I will ask a colleague to look into this.

However, I also note you’re not using an email address, like the default noreply address, to send your emails through the system.

If you got to Account Settings >> Routine Emails you have a warning there in a purple box.

An increasing number of email clients now reject mail from one address that is sent through a different server. In this case QuickFile is sending your mail but setting the “from address” as the one you’ve set on your account (which isn’t

The simplest way to fix this is to click the “fix this for me link” in the error box. This then configures QuickFile to send your mail from an address.

If you really want to continue sending mail from your email address then you would need to configure QuickFile to send from your own mail server. You can find information on how to do this here.

This will also help you increase the reliability of your emails, and decrease the chances of them being rejected or going to spam too.

Please let me know if I can be of further assistance.

Hi Thank you foryour prompt reply.
I have gone into the routine emials as suggested but there is no purple warning box there???
I was going to use that as a temporary fix until I had time later to se things up fully.



We have just this minute released an update to resolve the reverse DNS problem. Unfortunately this was a knock on effect of the outage last week. As a precaution we had to obfuscate our IP address behind Cloud Flare, which meant that reverse DNS lookups would have failed for any receiving email clients attempting to validate authenticity.

We have now migrated our SMTP to use a cloud based service, so reverse DNS, SPF and DKIM checks will all pass. I apologise for any inconvenience this may have caused.

Brilliant service. Thank you Glenn (and your team). It is really nice to know you do all you can to keep our data safe!

1 Like