Have invoices sent from our own email, rather than quickfile?

hi
invoices are sent to clients and the ‘from’ email address is a quickfile one.

clients then sometimes click reply, and send an emial, thinking they are emailing , i us, but it actually goes to i think mail@quickfile.co.uk

is there any way we can have the invoices sent out by quickfile sent showing they come from our emial address, so that it looks like we sent it, and if i client clicks reply it comes directly to us?

ive input the correct settings for gmail.
i get this error

It looks like there was a problem reaching your SMTP service
Error Message The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.7.0 Authentication Required. Learn more at

also, if thats correct and clients would email me and not quick file, why do i get these emails from quickfile?

email received from quickfile to me:

subject: Client email receiived

from: mail@post.quickfile.co.uk

body: the clients email that the sent to: mail@quickfile.co.uk


the client received my invoice.
it showed my name in the from part, but showed my email as mail@quickfile.co.uk.
so when they reply, it goes to that address.

ive got multiple quickfile accounts and tthis has happened on more than one occasion on more than one account.

the email doesnt go to me when they reply, it goes to quickfile, and sometimes quickfile forward it to me

just checked another of my quickfile accounts and emails.

clients have received invoices, clicked reply, and its been sent to:
mail@quickfile.co.uk

ive then got an email from mail@post.quickfile.co.uk with the subject as Client email received, and the email in the body.

i dont want clients to be emailing quickfile when they should be emailing us.

another update.
ive tried the same thing on another quickfile account.
adding smtp details for gmail.
it gives the same error.

im using:
port 587
from address: mine.
host name. smtp.gmail.com
username: myemailaddress
password: mypassword.
yse STARTTLS: Yes
send activation code: a different email of mine

gives this error:

It looks like there was a problem reaching your SMTP service
Error Message The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.7.0 Authentication Required. Learn more at
More Details –

just checked 3x different accounts.
when clients hit reply to an invoice, they send the email to mail@quickfile.co.uk

on your page, it states:

As standard QuickFile will email out any invoices, estimates and statements from mail@quickfile.co.uk , we will also set your own email address in the reply-to field, this ensures that if one of your clients hit reply to an email we send on your behalf, the response will come right back to you.

this clearly doesnt happen. 3x different quickfile accounts, multiple clients, all have emailed mail@quickfile when they have hit reply, not me.

Google no longer allow you to use your regular login email address and password for gmail authenticated SMTP. The recommended approach by Google for this situation is

  1. Enable “two step verification” for your Google account, if you haven’t already
  2. Generate an app-specific password
  3. Use that app-specific password instead of your normal login one when configuring QuickFile

Just to add to @ian_roberts’ reply, we also have a guide on using App passwords with QuickFile for SMTP: Using a 2-step verification Google Account with QuickFile

hi

ill look into this.

however, i have emails dating back before google stopped allowing that. i think it was may 2022 when google stopped allowing it.

i still have the issue that your guide says when clients hit reply it comes to me, but it doesnt and never has. it always goes to mail@quickfile.co.uk

if i have to enable 2 step v for my google email, i dont want to do that.
i dont want to use the google authenticator app on my phone every time i log in on multiple devices multiple times per day.

if i can do it just app specific only, then that would be ok.

hi
the guide suggests that the smtp wont work if i have google 2 step turned on.
i do not have it turned on.

You can’t - Google only supports app-specific passwords for accounts that have 2FA. If your phone is android then that 2FA can be a push notification to your android phone, it doesn’t have to be a Google authenticator 6 digit code. All the big tech companies like Google and Facebook are doing everything they can to push people towards more secure login mechanisms than just a single username and password, which is a good thing in general.

Prior to May 2022 you could configure a setting on the Google side to “allow less secure apps”, which would then let you use a plain username and password for auth SMTP. If you had 2 step enabled then you had to use an app password.

The former option is now gone - for auth SMTP you either have to enable 2 step and use an app password, or it requires work on the part of the developer of each piece of client software in order to support “sign in with Google” which is a Google extension to SMTP where you sign in direct with Google via a web browser, meaning the SMTP client never sees your actual Google password.

just setup 2 step.
added quick file as an app.
got an app password.
added it to quickfile

i got this message and all looks complete

Your SMTP Settings have been successfully activated!
All emails will now be routed through your mail server.

so i now asssume everything will be as though its from me

2 Likes

Hi,

From 2 days I have problems that you are not able to reach my SMTP server.
I changed configuration to another email address and it is still blocked.

Can you give me your IP address which you make SMTP connections? - I’ll check if it is blocked or not.

Hi @BNB

Due to the nature of our set up, the IP address used changes so we’re not able to reveal this I’m afraid.

Has the email setup worked all OK up until now?

Hi Mathew,

Yes, it worked ok until yesterday. And it stoped. None configuration works.

Mathew,

Do you have any sugestions?

Hello @BNB

I have just tested the settings you have and it worked successfully.

You will just need to verify it in your own account bey entering an email address you have access to in the “Send activation email to” box on the smtp settings screen.