HOME / COMMUNITY Switch to knowledge base

Headline Menus no longer working on FireFox

Hi, it may be my imagination but until very recently I would swear that clicking on the blue menu header (e.g. on the word “Purchases” directly below the FILE of the QuickFile logo) would have the same effect as clicking in the same place and then clicking “Show All Purchases” in the drop down menu that appears.

This is no longer the case which means clicking twice to get to the All Purchases view.

The same holds for the Sales and Reports menus; in fact the only item in that blue ribbon that now responds to a new view is the “Dashboard” one.

Has a recent upgrade removed this functionality? If so, can we have it back please?

Hi @Director

This isn’t something we’ve changed.

I’ve just tried this with FireFox 56.0 (32 bit), and this is still working all OK.

Has anything else changed that may have affected this? For example, are you using a different device? Have you installed any new extensions?

[Edit]
I just wanted to add that I’ve also just tried this with v57.0 and v57.0.2 (both 64 bit)

Hi Matthew,

Thanks for your quick response!

The machine I’m using hasn’t changed, although I have updated Firefox a few times in the last two weeks. Currently I’m using Firefox “Quantum” 57.0.1 (64-bit) - installed 30th November.

I have one Extension (Adblock Plus) which has been installed for years. There is also Shockwave Flash 27.0.0.187 which appears to have last been updated 15th November which has a ticked box saying “Block dangerous and intrusive Flash content”.

Any use?

I’ve just tried this on Windows 10 using FireFox 57.0.1 (64-bit), but this also seems to be working all OK.

Just to confirm that I’m on the right lines - when you click on “Sales” (as in the horizontal navigation), this reveals the drop down menu, and that’s all - it doesn’t take you to the invoice overview page, it just stays where it is?

Are you using a desktop computer? Do you have a touch screen?

So, I’m on Windows 10.0.16299 using a Lenovo x64-based laptop - no touch screen.

I updated to the recent BIG Windows 10 “Feature update 1709” on 25th November (painful!).

I have attached a screenshot which sadly doesn’t include my mouse pointer position but I have circled it in red. So, from the Dashboard view, if I click on the word “Purchases”, circled in red, all that happens is that the purchases drop down menu appears as shown. I must move the pointer down to “Show all purchases” and click again before I can see the complete list of my purchases. I think that up until maybe a week ago, clicking on the red circled area would take me straight to the list of purchases.

MenuClick

We have some mechanism here that disables the redirection on the menu header if the device supports touch gestures (e.g. tablet, phone and some laptops), this then enables the menu to be accessed without always redirecting.

I can only assume your device is wrongly registering as touch enabled for some reason? Maybe related to a FireFox update? We’ll continue to look into this and update you with any findings.

1 Like

I had the same problem and that was the fix for me. I was using a touch screen laptop. May have to clear cache also.

I have checked and found no evidence my Windows is configured for a touch screen environment. I have also cleared all my cache and re-started Firefox. Same result as before.

In case this helps…note that when I hover my mouse over “Dashboard”, I see the target https://MYSITE.quickfile.co.uk/dashboard address at the bottom left of my screen. Hovering over any of the other menu items (“Sales”, “Purchases” etc.) shows no similar addresses.

Thanks for your ongoing investigations!

Hi @Director

Thank you for checking. My colleague sent you a message with some tests. Did you manage to run these? You can see the message by clicking on your avatar in the top right corner, and clicking the little envelope icon.

Sorry, I didn’t notice the private message! Now answered. Thank you again!

1 Like