HSBC problem using Chrome Plug in


When I click on the bank feed icon in chrome, I get logged into HSBC but there are no accounts shown. Nor does it ask me for a secure key. I can find my accounts by navigating around but nothing is getting downloaded. It may be because I have two companies. When I log in manually I just select which company’s bank accounts I want to view. I’m guessing that the plug in may not be able to handle this as it does not know which account to choose. When I used Sage One (Yodlee) I was asked which company I wanted to use.

By the way, I’m using Chrome Version 58.0.3029.110 (64-bit) on MAC OSX 10.12.4

Hi @starkraving

As you’re probably aware, the Chrome plug in uses the standard HSBC website and pulls data in from there.

Can I clarify at what stage you’re being stopped at - if HSBC isn’t prompting you for a secure key, are you logging in manually (and I assume then HSBC would prompt you for the key)?

You should enter all the details into the QuickFile bar that shows up when you access the HSBC business website. It may download it automatically or it may show a “Export to QuickFile” button on your statement view page.

The chrome plug in works in a similar way to Yodlee but doesn’t run in the background - it needs Google Chrome to work. However, we do also offer a Yodlee feed if that’s something of interest for you. But with HSBC business accounts, it wouldn’t automatically update. You would need to refresh this manually.

I hope that helps

Thanks for the quick response. There are a few odd things happening. I’ll make a list and get back to you.

This is what just happened - not always the same issue.

Logged into Quickfile
Clicked on plug in and selected HSBC
Select log in from the top right - i.e. log in using plug in
All the account info is displayed and i was asked for the secure key number, but instead of “OK”, the only buttons were “SAVE” and “CANCEL”. I clicked SAVE
This logged me in and my two businesses were in the drop-down, so I selected the one I wanted
I selected my account and could see the Export to Quick File button.
However, I want to load transactions from October first so I selected statements. At this point the HSBC site presented a “Confirm Resubmission” page so I resubmitted this gave me the statements page.
I selected October, ticked “transaction Download” in excel format, then clicked on Export to Quick File.
I got the following error:
“Export Failed!
Incorrect account number or authentication key. Please ensure you have enabled file imports on your Quick File account and the credentials supplied are correct.”

I can do all this manually by downloading the transactions in Safari without the plug in, then uploading into Quick File.

Thanks for the details!

Can you confirm that you’ve enabled this in your account, and you’ve used the authentication key from within your account for the plugin?

Yes, I’ve just rechecked, and the enabled box is ticked and I used the authentication key from the bank feed settings.

I’ve just uploaded 7 months transactions manually but it would be nice if the plug in worked for me.

There are no issues with the feed at the moment; it appears to be working for other users all OK. It may mean that you have another extension that’s interfering with it.

The only thing I can really suggest is check try disabling some other extensions and see if that makes a difference. Also try checking for errors in the developers console (press F12, click ‘Console’, tick ‘Preserve Log’ and then try using the plug in).

Okay, thanks. I’ve only just installed Chrome today so any other plug ins would be the ones that came with Chrome.

The error you mentioned previously (“Incorrect account number or authentication key. Please ensure you have enabled file imports on your Quick File account and the credentials supplied are correct”) does really point to one of those details being incorrect. Can you please try re-entering them?

I’ve just tried the HSBC plug in with the following steps and it’s imported all OK.

  1. Select ‘HSBC’ from the QuickFile plug in:

  2. At the top, the QuickFile plug in bar should load. Click ‘Settings’ in the top right corner:

  3. Enter your details in the boxes:

    Note: The ‘Account Name’ has to be as it’s shown on the HSBC website

  4. Click ‘Save’

  5. If it doesn’t try to log you in automatically, click ‘Login’ in the top right hand corner on the QuickFile bar

  6. Once the log in is complete, select your account in the dropdown:

  7. View the statement of the bank account you’re trying to import, and click ‘Export to Quick File’ at the bottom:

  8. Click ‘OK’ to confirm, and wait

  9. Once it’s complete, you should see a pop up confirming this:

  10. Back in your QuickFile account, you then need to verify these, by clicking on ‘Notifications’, and then selecting the sync option:

    Note: It can take around 5-10 minutes to complete import and process these, so you may need to come back to this page

  11. When the import appears, click ‘Process’:

  12. Confirm the bank account you wish to import into:

  13. Click ‘Import Feed’

All done!

That’s how it should flow. If you follow those step by step, at what stage does it stop you?

Thanks! So it’s worked now.

I noticed that HSBC only allows 12 characters in the account name so it doesn’t allow the account name which is on my cheque book. I couldn’t see what the import key was in the plugin as its hidden but I overwrote it. One or the other or both of those changes did the trick!

The application looks good so far!

1 Like

This topic was automatically closed after 7 days. New replies are no longer allowed.