Invoice Inventory items lose line breaks when edited

I use inventory items to create new invoices or estimates in quickfile. The problem I am having is that when I edit the description of any inventory item, I lose all the carriage returns I have entered manually in the description of that item. In Order to get correct printout I have to re-insert all the carriage returns manually in the description field again which can be quite tedious when you editing many items. I was wondering if this is a bug or it is meant to work this way for some reason? I have tried using
instead of entering carriage return manually but this generates an extra blank line when I print the Invoice/Estimate. Any ideas?

Hi @harry

You’ll be glad to know that this issue is just isolated to the editing screen and not when you’re using them on invoices themselves.

I have however changed this topic to a bug report, and we’ll take a look.

No that is not quite true. If you go edit an existing Inventory item again and try to use it, You will find the carriage return is lost for good. This happens on the edit screen and also on the printout. The only way to over come this as far as I know is by re-editing the inventory item and re-inserting all the carriage returns I entered when I created the item or as I said using HTML <br> but using this introduces its own problem when printing as I mentioned previously

Hi @harry

I’ve just tried this from scratch. I’ve created a new item as follows:

Item Test
New Line

When I save it, this does indeed remove the new line:

However, when loading it into an invoice, the line is still in place:

And carried through to the preview and PDF:

Are you doing anything differently than the above, as I’m not able to replicate it? If you could walk me through what you are doing to produce this error, that would be great, and hopefully we can then fix it.

Re-editing does lose the carriage return.

This is logged so we will have a look today. The fix should be live by tomorrow.

yes that is true but if you go and re-edit that line again then the carriage return does not follow through. Allso, can you tell how to insert an image from quickfile here so I can show you problem

Hi @harry,

There’s a useful topic here to show how you can capture screenshots:

@harry, please check now. We’ve just made a small release that should address this problem.

Just checked everything seems to be working great. Great support as always.