Issue tagging foreign currency payment against multiple invoices

Hello,
I’m struggling to tag a payment.

The one payment relates to two invoices, which were invoiced in USD but the payment is received as GBP into our bank.

Quickfile has functionality to pay down multiple invoices from a customer payment, so I selected this option (having set the search range to 3 months as one of the invoices is overdue). I then searched for the client, however QF reports “No unpaid invoices found for this client. You can save as a credit to the client account below.”:

image

There are definitely two outstanding invoices for this client.

I tried instead to save it as a credit to their account, essentially as a pre-allocated payment and then to allocate afterwards, but I couldn’t work out how to do this.

Any ideas?

Thanks!

With a cross-currency payment like this you can’t do it by tagging the bank transaction, you have to start from the client overview screen - find them in the list of clients and click their name, then on the overview screen do more options -> new prepayment, then select “USD invoices”. From this view you can enter the exact USD and corresponding GBP amounts of the payment, and select the bank account that received the money, and it’ll create a new GBP transaction for the amount you entered (you can then delete the duplicate untagged one from the feed).

Once the client shows a USD prepayment balance you should be able to use log payment -> apply from credit on each of the outstanding invoices to mark them as paid.

Alternatively you may be able to skip the prepayment step if you view all invoices for that client, tick the boxes for the ones you want to pay, then use the button at the top to log one lump payment for all selected invoices. Again this will create a new transaction and you’ll have to delete the duplicate.

1 Like

Your alternative solution did the trick for me @ian_roberts, thanks :slight_smile:
I don’t understand why QF doesn’t find the outstanding client invoices from the bank transaction tagging, but this solution is simple enough.

This topic was automatically closed after 7 days. New replies are no longer allowed.