Login unavailable..."touchstone status"

Trying to go to the login in page…Google shows me that the site is insecure…I click proceed any way and arrive at touchstone status which looks like the image below. Please help.

Hi @rolyhudson

Can you confirm the URL you are using please and I’ll look into this?

I am using

That’s a bit odd. When I go to that URL, I see this (which is what it should look like):

I’ve asked a colleague to look into this

That is strange
I tried on chrome, firefox, and explorer and got the touchstone status page.
Going to reset the internet here and try again.
Thanks for responding so quickly

No problem - let me know how you get on! :slight_smile:
Fingers crossed

No change, reset internet and restarted computer but the url lacunae.quickfile.co.uk redirects straight to:
I get the touchstone status page!

Hmmm! I’ve even tried going to that page and it’s not found. Bear with me

I think it has something to do with my proxy IP…

Ah, that could be something to do with it. If you wish - send me a Private message (click my name and then ‘Message’) with any info you have that could help get to the bottom of this :slight_smile:

This topic was automatically closed after 7 days. New replies are no longer allowed.