Nationwide bank import

The import from Nationwide seems to have stopped working. The file consists of four header lines then the CSV statement table. The import program seems to be searching for the CSV statement table in the first 4 lines, where it isn’t. It worked fine until a few weeks ago - I can’t say when, I don’t get many transactions.

Hi John, I will send you a PM to get further details.

This again is related to inconsistent CSV output that some banks are using (same problem with Lloyds). The new parser we are using is much stricter so will hard fail if there are any inconsistencies.

We’re having to write specific workarounds for different banks as we find them. Nationwide has been patched and should be working correctly by about 5pm today when we next deploy.

Fantastic, thank you for such a speedy repsonse

No problem…It happened a little later than planned but the Nationwide fix is now live. I tested on small CSV and it worked fine. Let me know if you have any further problems.

This topic was automatically closed after 7 days. New replies are no longer allowed.