Office 365 SMTP Stopped Working "Security Defaults" App Passwords

Currently receiving the following message:

The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.7.57 SMTP; Client was not authenticated to send anonymous mail during MAIL FROM [LO2P265CA0276.GBRP265.PROD.OUTLOOK.COM]

I was previously using Azure AD Baseline Polices and recently transitioned to Security Defaults as directed by Microsoft due to Baseline Polices being phased out. Essentially this means I need to use app passwords for non-MFA compatible connections such as SMTP. This was working fine pre security policy change using app passwords, but hasn’t worked since. I have tried generating a new app password, but it’s still not working.

I’m curious about the ‘anonymous mail’ part, could you shed some light on this?

Hi @TechWizard

I’ve done a bit of searching on this, and it seems to suggest not to use Outlook as your SMTP server (which isn’t used for direct sending), but rather

If you have 2FA in use however, you will need to set up the app password to use for the SMTP.

For reference, this was the post:

This topic was automatically closed after 6 days. New replies are no longer allowed.