Purchase Order email - undeliverable to a specific address

Dear Quickfile

Having problems sending Purchase Orders to a specific email address namely: service@artpewter.co.uk. The email address is widely used and any emails from my own email programs are dispatched OK.

The error that I receive is as follows:

Your message did not reach some or all of the intended recipients.

Sent: 4 May 2015 11:19:46 +0100
Subject: Purchase Order - Tartan Time

The following recipient(s) could not be reached:

Error Type: SMTP
Remote server ( issued an error.
hMailServer sent: .
Remote server replied: 554 5.6.0 Invalid content


I would be grateful if you could advise on any solution.

Thank you very much


Are you sending the invoice as an attachment? It looks like a rule that has been setup on the recipient’s mail server to block messages with specific attachments or body text.

Dear Glenn
I overcame the problem by sending a copy to myself, just by adding my personal email address to the send emails addresses on the Purchasers send page and using the standard send button on the quickfile purchases page (as used to send direct to Supplier originally). It came through to me as a PDF attachment to my personal email address and I then just forwarded this email complete to the supplier from my server and they received it OK.

The recipients mail server therefore did not block from my email address and server. It appears to be coming from your server for some reason it would seem.

Would be grateful if you could have another look at it.

Thanks very much

This is your client’s mail server returning the error. If you ping mail.artpewter.co.uk it returns that IP.

When an email is sent from QuickFile, unless you have your own SMTP configured it will send from email@youraddress.com via mail.quickfile.co.uk. The client’s mail server sees that the domains don’t match and in some cases to mitigate spam they will reject it. That’s why when you send to your email and forward it works fine.

The best thing to do is to setup your own SMTP server on QuickFile or add an SPF record to allow QuickFile to send on your behalf. Both options explained in more detail here:


Dear Glenn

Thanks very much for your reply. Your solution, although not yet tried out, looks like it should resolve the problem OK.

Many thanks again.

1 Like