HOME / COMMUNITY Switch to knowledge base

Receipt Hub Tagging Foreign Currency Error

I have a supplier set as exempt for VAT.
image
When I select them as a supplier in the Receipt Hub VAT is applied.
image
If I select ‘VAT Exempt’ from the VAT options upon clicking save the wheel spins but nothing happens.
image
The only way to save it is to manually select ‘0% VAT’ or untick the box (which leaves the VAT set at 0%), which I shouldn’t have to do anyway?

Hi @Lurch,

In the supplier settings have you also set the default vat rate to 0?

I do now!

This is maybe just because I’m an electrician not an accountant but does the fact it’s exempt not mean it is 0% anyway? If I select VAT Exempt when in the receipt hub the VAT rate is set to 0% so would assume this is the case and the same should happen in the client control panel?

Hi @Lurch,

Yes it should! but they work as two different options, I have asked to see whether they can be linked/overridden if you chose the vat exempt option in the supplier settings.

We have replicated the spinny wheel issue though so have raised this with the dev team to look into

2 Likes

I see what’s happened here then. I just assumed that setting was irrelevant after selecting VAT Exempt.

In theory, zero rated should be 0% and exempt should be no vat, and out of scope should be excluded from any vat returns.

Have to remember that 0% is still a vat rate even if the result is £0.

Unfortunately quickfile doesn’t seem to grasp this very well.

… and in particular exempt sales should not be excluded from VAT returns (which I believe they currently are).

1 Like

Apologies. This should work as expected now.

@ian_roberts we will be updating the VAT exempt reporting shortly.

1 Like