HOME / COMMUNITY Switch to knowledge base

Reconnect quickfile

hello.

not used to this form of communication.

we have been using quickfile since start of vat on line.

we would an error when trying to send vat return error401.

i think we have to reset quickfile to hmrc.

i have disconnected quickfile, hmrc have sent a code , but i cannot use code it goes straight to my vat account with hmrc when logging in.

hmrc say i am connected there end no problems it your end .

can you help.

Hi @trowel,

Have you worked through this troubleshooter? Making Tax Digital: Troubleshooting

Once you have worked through this, please let me know if you are still having problems.

It may be that you have not removed the link with HMRC completely or have more than one connection

hi beth,

have tried everything. not sure were im going wrong.

i have 2 connected for 12th october. so it says. but when i enter vat return info and press sent to hmrc i keep having the error code.

Hi @trowel,

If you have more than one connection, then you’ll need to go into these connections and disable them, leaving the most recent.

This should sort out the problem :slight_smile:

ok beth, sorry to sound daft how do i do this, i dont appear to have a delete for any of them,

Reports >> HMRC

click on View
image

then click Disconnect
image

ive now disconnected all.

am i correct, press repots-vatretuns, then create - blank vat return form complete and send to hmrc.

how do i check if quickfile to now connected to hmrc, as i said id disconnected it, not sure if its reconnected.

Reports -> HMRC will list the accounts you have connected now, if there are none connected then you can click the connect button again.

If you have several different government gateway accounts (e.g. one for limited company taxes and another for your personal self assessment) then I recommend going to tax.service.gov.uk/business-account and actively log out there before you start the connect process in QuickFile, to make sure it sends you to the login screen and you can be certain you’re connecting the correct gateway account for your VAT.

1 Like

ok, ive logged out of hmrc account as you said.

when you say start the connect process in quickfile am i statring from scratch, as im not used to all this, wouldnt have been a problem only from reading after 18 months i need to reapply.

Just go to Reports >> HMRC click connect and follow the on screen instructions

ok beth, this is where im having problems, i follow the screen what to do,

i have been sent anaccess code. i now log into my vat hmrc account. it asks for vat number and password, it takes me directly to my vat account at hmrc, it does not ask for an access code.

so i now go to quickfile set up my vat return, press to send copy to hmrc and i get an error code 401, im back to where i started yesterday, im going round and round in circles.

Hi @trowel,

Check that your vat settings haven’t changed. You need to make sure that you have enabled online filing and ticked the mtd box. Once you have done this, then link your HMRC account?

ok will check, im going to check them leave the return till later, if im still having problems ill get back to you, what time is there someone i can chat to. thanks

Hi @trowel,

The Support team actively keep an eye on the forums during office hours so Mon-Fri 9am-5pm.

If you are still having problems later feel free to send a private message to @QFSupport with your QuickFile account number so that we help you resolve it

thank you you have been very helpful, not easy when not used to computers.

If you mean they’ve sent you a code by post, that’s usually only for when you’re first setting up VAT and haven’t yet attached your VAT number to your Government Gateway account at all. If you’re already able to see your previous VAT returns under the “Making Tax Digital for VAT” section of your HMRC online account then you’re already set up on the HMRC side and you just need to do the connection and configuration on the QuickFile side.

Under Reports -> HMRC you may already have your tax account connected, if not then use the “connect” button, select the “organisation” option (not “individual”), and it should redirect you to the Government Gateway to log in, then back to QuickFile to say the account is connected.

Then under Reports -> VAT Returns, press the “settings” button, then make sure that the two checkboxes for “enable online filing” and “use MTD features” are both ticked (the “use MTD” box only appears once the “enable online” box has been ticked"), and in the drop-down box for HMRC account select the account you just connected. Once you save these settings you should be able to go back to Reports -> VAT Returns -> Create and if it shows you a list of periods then you’re good to go.

You don’t need to re-apply to HMRC to be allowed to continue using MTD, the thing that expires after 18 months is the access token that grants QuickFile permission to interact with HMRC on your behalf. Disconnecting and re-connecting from the QuickFile side issues a new access token that will be valid for the next 18 months.

Yes. This I do understand. But not sure how to do it.

Can you talk me through.

  1. Disconnecting… want to check I’ve done it correctly
    2.reconnecting.
    Thanks