Sending Invoices by Email


I have been sending invoices by email with no issues until recently.
It has come to my attention that I have had a problem where the emails are not being received by certain email addresses. I have checked the junk and spam folders within these email addresses and nothing has arrived.

I have also set up SMTP Email settings in the relevant administration area of QuickFile and is proven to be working fine.

Is there any way of telling if these have bounced, been rejected or whether QuickFile has not attempted to send them for some reason? If they have bounced I can forward this information to the relevant people.

The email addresses are definitely live and correct as I have been sent emails by yourselves with technical support and other things and I receive these with no issues.


If you are using your own SMTP server, try logging into the email address you are using (assuming you have access to this email address directly). When you click on ‘Sent’, it should appear in there.

Have a look - let us know if anything is in there - it’ll help narrow down where the issue lies (whether its between QuickFile and your SMTP server, or your SMTP server, or the recipient).

Usually if an email is bounced you will get a response back to the address you’re sending the email from. The sender email is configured in Account Settings >> Routine Emails (scroll to the bottom).

If we dispatched the email to your SMTP server there should be a trace in the event log for that particular email. If you go to the invoice preview screen and scroll to the bottom you should see something like this. After that it’s down to your SMTP mail provider.

I have just set up to use my own SMTP server and Iknow my client recieved her invoice but the email doesn’t appear to be in my sent folder. This is not a major problem for me but means the only way I can know it has gone is if I ask the client.

I don’t think it necessarily would show in your sent folder, it really depends what email service you are using. In Quick File you can also track when an invoice is viewed by your client, look for the small envelope icon in the main invoice management screen.

Firstly, thanks for everyone’s input on this issue.

It seems it could be my email service provider. I have set up a different email address on the same domain and invoices come through every time. I have checked spam/junk settings on both the Server and on the
Exchange Client and nothing is blocked so not filtering into any specific folder and not being bounced.

What seems a little strange is that all QuickFile backups emails and information comes through without any issues to the email address in question so why would an email service just not show selected emails coming from the same source?

I have two email addresses on two different domain names having the same issue.

Anyway I have passed this back to my Email Host to investigate and awaiting their further response.

These backup emails would originate from our mail server, but when you’re sending invoices and you have your own SMTP server configured they would route through your server. Somewhere in your server logs you should have some indication of what’s going wrong.

It is actually an issue with my exchange service. Looks like there may have been an issue migrating from Exchange 2010 to 2013. If a new email address is set up from scratch on my domain using Exchange 2013, invoices come through fine. However where a current email address was migrated from Exchange 2010 to 2013, it won’t come through with no bounce back.
I have got my service provider to look into why this is happening.

I don’t have access to the logs hut I’m guessing my service provider will do.

This topic was automatically closed after 7 days. New replies are no longer allowed.