SEPA and Direct Debit issue? SEPA/DD is approved but not showing up under "More Options" to take payment

Hi Support,

I have a client who is in France and has accepted and approved a direct debit and SEPA etc… they live in France and have also set up the SEPA info etc… I have other clients in Europe and have already set-up others…

With this customer they have approved the Direct Debit (which is through GoCardless etc)… I can see their approved DD in GoCardless…

In their client info where it would normally show the DD is approved, green tick etc… It doesn’t show this… just shows the usual “Set up a direct Debit for this Client”… But if I click on it… it shows the GoCardless approved info and ID etc…?

It even states I can take a payment here… but I cannot within the invoice under more options…?

So I went to take payment via the More Options in the invoice I have just issued to this client… but it does not state the Take payment via Direct Debit?

I have taken payment via DD and SEPA with other European client so I know there is something wrong in this particular instance… Can you advise?

Kind Regards,


Hi Support further to last message…

I think I know the reason why this (the above), has happened… I have just gone to invoice another client who is in Portugal… I have successfully invoiced and taken payment before… but it was in GBP… although it was successful it took x £ as euros… so it was under in payment… I have today gone in and changed this client and the French client to from £ GBP to Euro…

I have now come up against the same issue with the Portugal client as I have with the French client… So I am guessing it is to do with me changing the client payment currency from GBP to Euros…?

The Portugal client no longer shows under the “more options” the “Take payment via Direct Debit”…

Can you advise how I now associate these invoices with the DD/(SEPA) info… Is there some other setting I need to adjust?

Again thanks in advance



We never officially developed the GoCardless DD integration to work with foreign currencies (only GBP), I don’t even think it is supported on the API we’re targeting, although I am aware GoCardless have since developed a new product called “GoCardless Pro”. We will have a look at the spec. to see what’s possible and I’ll get back to you. I’m 95% sure we can’t support foreign currency with GC at this time.


I have confirmed that at this time our integration with GoCardless will not support SEPA payments only UK Direct Debits. None of the pre-authorisations you setup on QuickFile are actually SEPA payments, although you may have other SEPA pre-authorisations that were setup directly in GoCardless.

We’ll monitor the support for this feature going forward, if there’s a clear requirement amongst our userbase for SEPA we’ll look at extending our integration.

Hi Glen,

Thanks for looking into this… I can confirm that I have taken payments before via DD from a European customer… but when I did the customers currency was GBP…

For example if it was say £100… When I was paid it came in as 100 Euros… (so was less in GBP than it should have been due to being Euros)… So I know I can take a payment via the DD setup with them… In this instance I had changed the clients currency to Euro… hoping I could then input the correct amount of euros to give me the correct GBP if that makes sense…

I’ll just put their currency back to GBP and compensate the charge to come in as the correct amount…

For reference in my GoCardless I have the extra SEPA payments setup to allow payments from European clients etc.

Kind Regards,


Hello Again Glen,

Just to let you know what I have done… I have just changed the clients currency back to GBP and then returned to the invoices generated (which have already been sent)… I then modified the invoice to GBP and this then allowed me to take payment via DD… being as the invoice amount was originally in Euros the amount reflected will still be correct as even tho the amount now says GBP when I receive the payment via GoCardless it will actually be taken in Euros… so will now work out correctly… again I hope that makes sense :smile:

Kind regards,