SMTP Settings - Gmail stopped working

I’ve been using Gmail to send invoices via SMTP for a while now.
However today, it’s stopped working.

QF message: “The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.7.0 Authentication Required. Learn more at”

I also got a Google Security alert, Sign-in attempt was blocked.

Checking the Google security settings, I could see that “use insecure apps” was turned off, so I switched it on…
Sill getting email errors in QF and mo messages being sent.

Any suggestion?

Google requires 2 step auth. from 1/1/22, could that be the problem?
Do you use a app password for quickfile? If not, have a look here:
Sign in using app passwords - Gmail Help

Thanks rch,

That could be the issue… Just need to work out how to enable 2FA and app passwords on my Google Workspace account… Currently it’s just not letting me set up 2FA even…

To fix this I had to.

  1. Log into my Google Workspace Admin area and allow users to set up 2FA
  2. Log into my Google Account and enable 2FA for my email
  3. Once 2FA was set up then I could see the option to create an App password.
  4. Followed the App password wizard, using the mail and Other Options.
  5. In QF, delete current SMTP settings.
  6. In QF, add in SMTP settings for Google, use the new App password from (4)
  7. Send an Activation email to another address, then enter the code to complete QF SMTP setup.

It’s all working again now!

1 Like

Great to hear you managed to resolve this @Stephen_Greenslade! I’m sure this will help other users too

This topic was automatically closed after 7 days. New replies are no longer allowed.