Stripe transactions missing


I’ve noticed there are missing transactions (processing fees) from Stripe when clients make card payments via their invoice through QuickFile.

We have Stripe integrated with a website that takes payments and we also invoice clients who pay via Stripe.

The transactions from the website show in Stripe with the processing fee - this is correct.

The transactions from clients who pay their QuickFile invoice using Stripe shows their payment in to Stripe (correct) but the processing fee from stripe is missing (not correct).

The transactions are all listed correctly when I log directly in to Stripe but in QuickFile’s Stripe feed they do not appear.

Is this an issue with QuickFile or Stripe?

It is correct - you need to record the full amount (before stripe deducted their fees) as income, and then record the fees separately as an expense. Stripe provide you with an invoice during the first few days of each month for the total fees charged during the previous month (under “business settings” -> “documents” on your stripe dashboard) which you can treat as a normal purchase in QuickFile paid from the stripe holding account. This will account for a whole month’s fees in one go so you don’t have to record each one individually.

In fact, if you’re VAT registered then you must do it this way as you have to reverse-charge the monthly fee invoice.

Hi Ian,

I’m not sure you’ve understood the issue. We already record the stripe processing fees for VAT / reverse charging.The issue is the stripe processing fee transactions are missing for card payments made via QuickFile invoices only


A customer makes a £9.99 payment via our website. The QuickFile integrated Stripe bank feed shows:

  • in £9.99
  • out £0.34 (processing fee)

This is correct and we tally the processing fee payments with the invoice from Stripe

The next example is where the issue is:

A customer makes a £9.99 payment via an Invoice from Quickfile. The QuickFile integrated Stripe bank feed shows:

  • in £9.99

The processing fee is missing from the feed, meaning we now have to manually add it in. The transactions are correctly listed within our Stripe account when I log in but they are missing from the QuickFile Stripe bank feed.

Does that make sense?

Hi, any help out there on this issue please? :grinning:

I do t work for QuickFile, you’ll need to see if @QFMathew has any thoughts.


If your client logged into QuickFile and paid using Stripe, the Stripe fee isn’t currently added to your account.

As Stripe invoices you for the fees on a monthly basis, it’s probably best to bulk log them when they invoice you and record it as one transaction.

Thanks @QFMathew

Is there any specific reason for this? The Stripe fees are all listed when I log in to Stripe.

They’re just missing from QuickFile - is this an issue with Stripe or QF?

The payment processing works independently from the feed, so you can have the one enabled without the other. By design, the processing fee isn’t included as it’s easier (and uses less nominal ledger entries) to bulk enter the fees on a monthly basis to match the invoice.

We can certainly consider changing this, or allowing it on a per-account basis.

Hi @QFMathew

I’m not sure I follow? What can we have enabled / disabled independently?

The stripe feed automatically shows processing fees e.g.:

But they are always missing for payments made via QuickFile invoices. Surely if QuickFile is connected to Stripe and pulling in all transactions, it can pull in all processing fees?

I don’t understand why all processing fee’s aren’t being displayed in our feed? It seems inconsistent.

@QFMathew - apparently this topic closes in 30-mins, how do we continue with it?

Maybe the simplest option would be to add another checkbox to the feed settings to make it ignore all fee transactions the same way as you can have it ignore payout transactions. That way you could more easily account for the fees in bulk based on the monthly invoice.

To give a bit of a better idea here, when the feed runs we check all your transactions that have happened since the last feed update. Before we insert anything into your account (like with any bank import or feed), we check for duplicates.

In this case, payments taken through QuickFile are automatically recorded, so a transaction already exists for these. As a result, when it’s received from the feed it’s flagged as a duplicate and skipped - which is correct.

The Stripe API doesn’t allow (as far as I’m aware) an overview of just the fees. You can view the transactions, and the fees associated with it. So when the feed skips the transaction, the fee is also skipped. If that makes sense?

Sorry - I mean pretty much what @ian_roberts mentioned - adding a checkbox or an option to turn the fees on/off on an account basis.

I’ll discuss this with our team and see if this could be an option. We’ll let you know if anything can be changed here.

I’d be on board with this too as I can get myself quite confused when reconciling Stripe payments (making sure they are grouped per VAT period etc). If the fees were downloaded with the payments it would make this relatively painless.

@QFMathew - that makes perfect sense, thank you :grinning:

I think @ian_roberts suggestion to add an option to disable the processing fees would be the best approach, otherwise I’m getting a mix of transactions with and without processing fees and it becomes a bit of a headache.

It would be far simpler to have no processing fees at all and just use the invoice from Stripe each month. Would save a lot of tagging!

1 Like

This topic was automatically closed after 10 days. New replies are no longer allowed.