HOME / COMMUNITY Switch to knowledge base

Tax Account Authorisation?

I’ve been using Quickfile since 01.04.19 and have successfully submitted 2 vat returns with no issie but now I cannot raise/submit a vat return :
Your Tax Account authorisation may have expired. Please try to remove the existing link and reconnect on the HMRC Connect page.

When i click on HMRC connect I get :{“error”:“server_error”,“error_description”:“unexpected error occurred”,“state”:“e84ab9e8-f4c8-4774-ba89-bcc93aa55b6d”}

Do i need to actually remove an existing link? How to?

Did you resolve this? I’ve just come across the same error and, having followed the suggestion of removing and re-adding the account it now tells me I need to wait 24 hours - not a great system when I’ve left the submission to the last day!

Hi @Mark_Manning

Are you seeing the same error message as above?

This usually only applies to those who have just signed up to MTD, but I’m guessing this isn’t the case for you? What is the exact message you’re seeing at the moment?

I don’t recall the exact message, other than it saying that I needed to wait at least 24 hours. Having waited (longer than) 24 hours it’s now just giving me the message “HMRC returned a server error, this usually occurs when their service is temporarily down for maintenance.”. It’s been like that for an hour, so no idea if it’s really temporarily down or another issue with my account!

Scheduled maintenance to the Making Tax Digital (MTD) VAT service will take place between 17:00pm Friday 11 September 2020 to 9:00am Monday 14 September 2020

During this time customers will be unable to access the VAT MTD online service.

Its unlikely this is related to your original issue, but the message you receive has now changed due to the above.

It sounds to me like you have either set up the mtd link wrong or you have perhaps left an old non working link under your hmrc tax account settings. You can only have 1 working account setting under this section, any other non working or failed attempts need to be detached. Obviously you won’t be able to solve this issue until the maintenence has ended.

Hi @Mark_Manning,

Have you managed to try again since the maintenance has finished? are you still seeing an error?

Now that the maintenance is finished it’s back to the previous error of " You are not yet authorised to view this report for the VRN xxx yyyy zz . Please ensure your VAT number is correct and you have connected the corresponding HMRC Tax Account. If you have recently enrolled on the MTD scheme please allow 24 hours for HMRC systems to update."

Yes, the actual VAT number is in there and yes, it is correct.

I have tried de-linking and re-linking the account again and noticed that the registered postcode was the previous address. I updated that whilst re-linking but still have the same error as before.

Hi @Mark_Manning

Can I just confirm, when you mention that you’ve de-linked it, have you literally clicked “Disconnect”, or just disabled MTD on your account?

This may help: Making Tax Digital: Troubleshooting

I honestly can’t remember what the option said, I just followed the suggestion listed on the first error message. When I look at the VAT settings now, I only see check boxes for ‘Enable Online Filing’ and ‘Use MTD Features’, both of which are ticked. All I remember about the process was that I disconnected (using whatever button or check box I found at the time) and then immediately tried to reconnect, at which point I got the log in window asking for my username and password, which I entered and then got the error I am getting now.

Hi @Mark_Manning,

Have you worked through the guide that my colleague linked above and you’re still having issues?

Thank you both, I must have reconnected with the wrong account initially and then even though I’d tried using the correct account on the VAT Settings screen it wasn’t using that account.

Why is it that the VAT settings screen (…/secure/reports/VatReturns/settings.aspx) and the HMRC report screen (…/hmrc/connect) both present the login request, but only the latter correctly links up the account?

Hi @Mark_Manning,

I’m glad that it’s all sorted now :slight_smile:

I will double check the reasoning behind why it works the one way but not the other, I will let you know asap

Hi @Mark_Manning

With the VAT submissions, it uses the account defined in the VAT Settings (Reports >> VAT Returns >> Settings)

The VAT return screen shouldn’t actually present the option to select an account. If you’re seeing this, drop @QFSupport a private message with a few more details, and we can take a look at this for you :slight_smile: