HOME / COMMUNITY Switch to knowledge base

Trying to file VAT return with HMRC

Hi Beth, I have been at this for hours.

You help/support is greatly appreciated.

Account = [ Removed ]

Thanks, Allan

Hi @allanh,

You had ‘enable online filing’ unticked. I have now enabled this and ticked for MTD. Please could you try and link with HMRC again now?

Hi Beth, I did tick these 2 boxes, each time. I try to send

It does say save, BUT AIN’T saving.

The online enable, tick, I have to tick every time I try to send

Still getting a messge in RED saying authenticationfailure etc etc etc.

No joy on HMRC actually getting the filled form?

Thanks,

Allan

Hi @allanh,

are you able to provide any screenshots of the error? and have you tried to connect your HMRC account again before trying to file the return?

Hi Beth, I’m locked out or similar.

When I try to connect to HMRC, I’m getting the old message

"you are not yet authorised to view this report for VRN XXXXXXXXX.

Please ensure your vat number is correct and you have connected to corresponding HMRC tax account. If you have recently

enrolled on the MTD scheme please allow 24 hours for HMRC systems to update."

I will leave it for today, and try again, tomorrow.

Will leave you in peace. and thanks,

I will have another go tomorrow.

Allan

Hi @allanh

If you’re seeing an “not yet authorised” message, it’s likely to be caused by your enrolment to MTD, or some sort of permissions with HMRC.

We have a troubleshooting guide, with a section on this, which may be worth checking out: Making Tax Digital: Troubleshooting

Thanks Mathew,

I have been, through this as you suggested, went through it yesterda, also this morning had anther look, before I contacted

you guys at quickfile.

I will try in 24 hours, again.

But thank you

Allan

Hi @allanh

Just a quick message to see if you’re still experiencing issues with this?

Thanks,Matt, I was out all day, so leaving the vat/hmrc for tomorrow. I will let you no, tomorrow, either way. Regards, Allan

Morning, still cannot get into HMRC to file a VAT return.

I will need get this return to hmrc, soon.

I am still getting
YOU ARE NOT YET AUTHORISED TO TO VIEW THIS REPORT FOR VRN XXXXXXXXXX
ENSURE VAT NUMBER IS CORRECT TO THE RIGHT hmrc account, etc etc etc

So nothing has changed from 2 days ago?

Help!

Hi @allanh,

Have you made sure that you’ve connected the correct account? Some people can have more than one gateway account. You need to make sure the link is for the company not the individual

Best way to make sure is to log out from HMRC on your browser and then when you go to re-link you shouldn’t have anything autofilled

Morning, I’m now getting
"MTD is now live, please enroll for MTD within your HMRC account, etc etc.

I enrolled 18 months ago.

Not sure now where to go for HMRC account?

Thanks, Allan

Hi Allan,

If you go to your government gateway account outside of QuickFile you make sure you aren’t logged in there before connecting through QuickFile.

It may be worth getting in touch with HMRC to make sure nothing has changed on your account

Hello again,

Managed to TRY and send a vat return, BUT, now

Getting message, saying
Authentication failure, the supplied user credentials failed validation for requested service.

Not sure where user credentials are located, is this at your end or hmrc?

Thanks,

Hi again, HMRC are saying check with the software provider for issues,

they are saying problem not at their end. thanks.

When i submit the vat return.

I get a message saying =
BY GATEWAY "authentication failure the supplied user credentials failed validation for requested service.

Do we know if BY GATEWAY is your software or HMRC’S software.

I am as a Ltd company, granted Quickfile as my MTD service as I checked out by HMRC.

Hi @allanh

If you’re seeing “GATEWAY”, it would suggest you’re using the old VAT submission rather than the Making Tax Digital one.

If you go to your VAT settings (Reports >> VAT Returns >> VAT Settings), is “MTD” ticked, and is the correct HMRC account selected? You can also check this on the HMRC page (Reports > HMRC).

Missing credentials usually suggests that the authentication process didn’t complete correctly. Removing the HMRC Account and re-linking it will usually fix this.

The VRN error message (“you’re not authorised”) is often related to either the wrong HMRC account being linked (e.g. you’ve linked your HMRC account for corporation tax rather than VAT), or you’re not enrolled for MTD. Given that you’ve used it for 18 months, I would think it would be the wrong account.

Morning I think we are now on day four, with this problem.

Question?
If I cancel opt out of my present quickfile MTD with HMRC.

Start again and opt back in. As a new client with quickfile.

Is this simple to do.???

Do I register as a NEW client with Quickfile, and any previous history with quickfile gets wiped out.

thanks

Hi @allanh,

You don’t need to re-register. You just need to re-link the correct HMRC account to your QuickFile account:

You don’t need to enter the User ID, you just need to tick the Use MTD Features box and connect your HMRC account through Reports >> HMRC

The process that should work is as follows:

  1. Disconnect all existing tax accounts from reports -> HMRC

  1. Click the “connect” button and connect the HMRC tax account that you use for VAT (if you have more than one HMRC account, e.g. one for VAT and a different one for Self Assessment, then you must connect the one that is registered for VAT and MTD. If you’re already logged in to HMRC before you click the connect button then it might just connect that account rather than asking you to log in, so if you’re unsure then actively sign out of tax.service.gov.uk/business-account before you press connect). You must connect as an “organization”, not an “individual”

  2. In reports -> VAT returns -> settings, ensure that both “enable online filing” and “use MTD features” are ticked, and that you have selected the tax account you just connected in the drop down box

The VAT number at the top of that page must match the one you’re trying to file, it should be just the nine digits with no spaces or GB prefix.