Unable to allocate credit to a foreign currency sales invoice


We have received a payment from a client who we invoiced in Euros. Our bank has converted the euro payment to GBP. Naturally, when we try to tag the payment, the system doesn’t automatically match the payment to the client invoice (because the GBP amount received does not match the Euro amount on the invoice).

Instead, I allocated the payment to the client account as a credit, then went into the client account, selected the invoice and clicked ‘log payment’. I expected to be able to allocate the credit to the invoice, but I am not being offered this option.

Am I doing something wrong?



You can allocate a payment made in GBP to a non GBP Sales invoice, although you cannot use tagging. Follow the steps below:

  1. Select the Euro sales invoice entered onto Quick File and click ‘Log Payment’, now enter the actual amount received in GBP from your client, as shown on your bank account, also enter the full EUR amount if the invoice has been paid in full. Finally, select the current account the payment was made to, the method of payment and click to ‘Save’:

See the example below:

  1. Once you have completed the above steps, there will be a duplicate transaction on the bank if you’re using bank feeds and/or uploading your statements, therefore you will need to go to your Bank Account and delete the duplicate untagged foreign payment.

This topic was automatically closed after 7 days. New replies are no longer allowed.