Unable to link Baclays Bank account feed

Hi -

I upgraded to the full version this week and have been able to successfully link our Santader business account, however, I’m unable to link to our main Barclays Bank account.

I have emailed Barclays support, received a response and just called them and they are unable to help, as quickfile isn’t listed as an app provider (Quickbooks, Xero, Sage etc are).

  • Within quickfile, I’m able to select to create a new feed.
  • Select Barclays
  • I’m redirected to the Barclays login page
  • Login to Barclays
  • Briefly see my accounts home page, then the page refreshes to show “Sharing your data”… “Choose the account(s) you want to access to”…
  • There are two tabs - Personal & Business - on each tab I can see all my accounts
  • I select business, but on any of the accounts listed, I’m Unable to click the Checkbox to select the account. For all accounts it’s like this, the checkboxes are greyed / not selectable… and the [Continue] button remains greyed out
  • When you try to click, it shows a blue select highlight around the “Chose your account(s)” frame.

I’m using a mac, have the latest OS, browsers. Have tried clearing cache, cookies, restarting - always the same.

Barclays initially suggested installing Java and updating the browsers. I installed Java on the machine, however, if you read the Java support page it explains all browsers on OSX now block the Java plugin, so this is not possible. https://java.com/en/download/help/enable_browser.xml

Please help - it’s the start of our new financial year tomorrow and we were hoping to go live on QuickFile - I’m being pressured to move to Xero!

Thanks -

When you logged in to Barclays did you use pin sentry or memorable word? I’m sure I’ve read other people saying the open banking setup only works if you log in with pin sentry.

Failing that you may have to visit the bank branch as there have been other reports of the bank not permitting the open banking feed if they don’t have an up to date signed “mandate” on file.

I had to ensure Barclays had a fully filled in mandate from me, including my signature. After this, the open banking feed worked. (As posted above, ensure you’ve used the PINsentry or Mobile PINsentry to log on to your Barclays online banking)

I use a Mac, and don’t have Java installed. Try using Chrome as your browser to connect to open banking, as it worked fine for me - it’s possible Barclays aren’t fully supporting Safari on a Mac as the browser.

Also, Barclays support don’t generally understand open banking at all, hence the fall back to “not supported”, but if you insist they escalate it to your business manager, it can get sorted out.

Hello @redfox

Welcome to QuickFile!

What @tellytart and @ian_roberts should hopefully fix this for you.

But to reiterate one of the points above - Barclays does support QuickFile through Open Banking, and them saying otherwise is incorrect.

Any problems, please let us know.

Firstly many thanks for the swift replies.

@ian_roberts I used Pin Sentry within the mobile app - which works to get you logged in. I’ve just tried it with my debit card and the hand-held Pin Sentry and the same thing - takes me to the tabs to select the account however I’m unable to click to select anything.

@tellytart & Matthew- I’ll contact my bank manager tomorrow and let you know - Barclays support did put me through to their integration however their conclusion was not supported!

Thanks again.


Hi Tim,

We can escalate this issue directly to the Open Banking team at Barclays, I think that will be more productive than trying to resolve via their 1st line support.

I will send you a private message to discuss further. Look out for a green notification in the top right.


Good evening
I’m also struggling with setting up the Barclays Open Banking feed. I have tried several times and all but once, I got the result in the attached. Once it allowed me to login to the Barclays account and I was able to select the account to allow access to but unfortunately when confirming an error occurred and I’m unable to get back to this page again.
Hope you can help… bit annoying that the Chrome version worked and now I am paying for it, it doesn’t.

Hi @jtaylor1

I can see a few errors being flagged up to our development team, so I’m sure they’re investigating it. It’s likely that this is an error on Barclays’ side, but I will be able to get further information from our team in the morning.