Yodlee Feeds Creating Duplicate Entries


I have just started using the Yodlee Feeds and they are causing duplicate entries for one of the I DJ for. I email my invoice to them weekly via QuickFile and have until now been marking the invoice as paid when the money goes in to my bank three weeks later. Now I am using the Yodlee Feed it is importing the payment but I can’t get it to attach to the outstanding invoice and mark it as paid. When I manually mark the invoice as paid it isn’t recognising the transaction Yodlee has imported and is creating another entry in to my bank account.

Hi @MightyGroup.net

When Yodlee passes the transactions into QuickFile we check for 3 things by default:

  • Date
  • Description
  • Value

If all 3 of these match, then we mark it as a duplicate (however we don’t discard it, we just keep it separate so it can always be imported if you needed it). We have just made a change here so you now have the option to check for duplicates based on just date and value.

When you mark an invoice as paid manually, it will create a transaction with a generic description (e.g. “Payment from Client A”) so this clearly wouldn’t match your bank statement. Depending on the values of your transactions, changing the duplicate check option, may be the better option for you.

Is the invoice already paid in full? If so, this would be why. But if you want to provide me with a date of a transaction and an invoice number, I’ll take a look for you.

Hi, the invoice is now marked as paid as I have been trying to work out how to get them to merge together but it wasn’t initially. 07/04/2017 - 000283

When you say “merge together”, or do mean actually merging bank transactions, or matching up a transaction to the invoice?

sorry I mean matching it up so that it marked the invoice as paid automatically

The bank tagging rules aren’t able to update an invoice as paid automatically for a few reasons.

I can see the two transactions there in your account, same value and date. You can safely delete the untagged one and that should balance things out again for you. Having the bank tagging rules set up the way you do (confirm before tagging) will certainly help prevent duplicate invoices being created too.

I think either changing the duplication check (More Options >> Bank Feed Details) or just waiting for the transaction to import before tagging is going to be the way forward.

Ok thanks for your help :slight_smile: