Invoice item line is incomplete: Missing item description


Please forgive me if I’m overlooking something but having read the posts below I’m pretty sure all fields are complete yet I still get the error “Please check, the item line is incomplete: Missing item description”

Hi @Mark_Wyllie

The “Description” box itself is empty in your screenshot. Although the category is showing, this isn’t part of the description and doesn’t show on the invoice itself.

In your case, where your item is “Services”, I would add additional information to the “Description” box to describe the exact services being offered so your client can clearly identify what the invoice is for.

I hope that helps!

That’s great. Thank you. However, now that I can preview the invoice, any idea why my company address is duplicated on the left (the client address is shown correctly to the right)?

It may be the case that it’s been entered twice on the system. A common cause is because it’s been entered as “text to show below my company address”.

If you go to Account Settings >> Invoice Customisation >> Click the box where you company address is (top left).

This will reveal a box on the right where you can check this.

If that doesn’t help, please let me know and I’ll take a quick look for you.

Yes I had a look there earlier and the company address is only entered once. Thought it might drop the duplicate address if “Hide my company address on invoices/estimates” was unchecked but that results in no company address shown at all. Would be great if you could take a look if possible?

I’ve located your account and taken a look. There’s a text box shown on the page mentioned above, labelled “Display the following text below my company address”:

In relation to your account, this box has your address in there. Unticking the “Hide my company address” box, and removing it from the text box will mean your address is only shown once.

By default, we always show your company address on invoices, so adding it below your company address will duplicate it.

Hope that helps!

Of course - more coffee for me this morning :wink:

1 Like

Sorry, last question on invoicing. Is there any way you can reset the invoice numbers as, now that I’ve corrected the format and deleted the first drafts, I’m not able to reuse the original invoice number.

i.e. “The Invoice Number ‘XXX001’ has already been used. Please provide a unique Invoice Number”

The only way to do this would be to renumber the deleted ones (restore them, update them, re-delete them).

We don’t allow invoice number re-using as this then keeps a clear audit trail should HMRC query it at any point.

Understood and thanks again. Any idea why the invoice system calculates £881.19 when adding 20%VAT to £734.34? Should’t this be £881.21 (734.34 x 1.2)

I’ve located the invoice in question and I can see you have multiple lines to the invoice itself.

The VAT is calculated at a line level, so if you have multiple invoice lines at 20%, it’s calculated on each of those lines and then added together to produce the end figure. This in turn causes the slight rounding difference, but is in fact correct.

What you may wish to do, is enable line VAT, which would show you the VAT amount for each line. This can be enabled from the same page as above (Invoice customisation), by clicking on the item area and ticking the box to show this. That should make it a bit clearer.

Forgive me once again for raising what is probably obvious to those familiar with accounting software but could you kindly outline the steps to ‘tag’ a paid invoice to an existing bank transition (imported via Yodlee)? Having (a) created a ‘new client’ then (b) created a ‘new invoice’ for that client, I then © ’log payment’ to link the paid invoice to a bank transaction. This results in “A Payment of GBP XX.XX has been attributed to this invoice’ which is now fully paid up and is added to the account statement. I then (d) must delete this duplicate transaction from the statement in order to (e) ‘tag’ the actual transaction (imported via Yodlee) which “links this invoice to the bank transaction” Is there a more streamlined method of achieving this?

You don’t need to use the Yodlee transaction if you’d prefer not to - you could delete it as that one would then be the duplicate. But yes, that is likely to be the way to handle it.

The only way to prevent this would be to switch the duplication checking for Yodlee. By default, QuickFile checks the date, description and amount to see if it’s a duplicate when pulling in the data from Yodlee.

Assuming your first transaction entered is using the same amount and date, you could update the duplicate policy to check for only date and amount, which would prevent the Yodlee one being imported. The only thing to consider here, is if you have many transactions on the same day for the same value.

To change this, go to the bank account with Yodlee enabled, go to More Options >> Bank Feed Details, and change the duplicate policy there.

This topic was automatically closed after 7 days. New replies are no longer allowed.