Open Banking Feed doesn't work (Revolut)

Hello, in February I set up the banking feed for our Revolut Business account during the trial period, and it worked correctly.
Today I purchased the subscription, the Revolut bank account is still in the list, but when I click on it’s bank feed settings the webpage is empty in 50% of cases, otherwise it shows an error (I tried many times for more than 15 minutes):

The bank failed to respond and their Open Banking interface may be down. Please retry in 15 minutes.

The same is happening when I try to “Connect a bank” again, and choose Revolut in the list:

Worths mentioning that your “System health” page declares that “Revolut open bankings feed” should be operational:

@QFSupport I hope you could help :pray:

I also tried to logout and login again; to use a different web browser, nothing helps.
Revolut Business support says their systems are operational and that’s an issue on Quick File’s side.

Hi, Do you try to connect the same feed? If so, it is maybe worth to delete the feed completely (also unlinking the bank account from the feed first) and setup a completely new feed.
It is maybe also possible that revolut is doing something on their end. Days like today are very often used to do some work on the banks server/system because not many people are banking today. To wait until Monday could maybe solve the problem.
Also, if not done already, double check that the bank account within quickfile is setup as Revolut (you should see the revolut logo on your bank account screen).

Thanks for your reply! I tried to connect again many times, it doesn’t help. I see no option to delete a feed or unlink a bank, unfortunately.

Hoover over Banking (top menu) and click Open banking feed. You should see your feed with status. On the right hand-side is a revoke button


If you click it it will delete the feed.
If there is no feed and you have tried to connect one then I would say there is a bigger problem, very likely on revoluts side (but can be wrong) and you have maybe to wait until the support team is back on Monday. Sometimes they are checking from time to time and they can help you earlier.
Sorry I couldn’t be more helpful

The problem is that no feed is shown for me, every time I try to connect it again, the webpage is empty again. QuickFile somehow ignores that previously this bank was already added and even synced once.
On the screenshot is what I see on the open banking page:

Hello @NightStory

I just checked our end and we have had some Revolut feeds updating successfully.

Their status page suggests no issues, normally I would suggest contacting them directly.

If you have tried as @rhc said (revoke/delete the feed and set it up again) it may be worth waiting until Monday, if the issue has not resolved its self (try to reconnect on Monday) then contact Revolut directly.

Our support team will also be back on Monday to help you.

@QFSteve thanks for reply, it definitely seems to be a bug on your side as there is this bank feed available in the list of bank accounts but not on the bank feeds page. I already contacted the Revolut support and they confirmed there is no issue on their side.

Let’s even imagine: right now something is wrong with Revolut. But back in February I already added this bank feed and even synced it at least once. Why don’t I see that bank feed in the list? Why can’t I revoke it as it’s shown on @rhc’s screenshot? So I can’t do the clear reconnect.
Could you please reset it somehow manually for my account, if your website has a bug and doesn’t allow me to do that? Thanks!

@nightstory @QFSteve

I have the same problem, I noticed my Revolut feed was due to expire so went to refresh. I get the same error message, so i deleted the Revolut feed now cant reconnect. Revolut support have also advised me all ok at their end. Regards Dave


I still cant connect. Screenshot from this morning

I have similar issue and it seems this problem happens to few customers only not for all of Revolut customers.

1 Like

I passed this to our development team who are looking into it

1 Like

Good morning Steve, an update from the developers on this issue. I’m still unable to get the Revolut feed working.

Hello @dmarti32

I had news from the development team who advised they have reached out to Revolut but have as of yet not had a response from them.

@QFSteve Any update from the development team? I still connect the Revolut Feed. Txs

Hello @dmarti32

We’re still in communication with Revolut and working to resolve this issue. We will post any updates to our status page

I see some progress is being made as I have been able to map Revolut to QF. Can’t progress beyond this point. Are the dev team able to provide any update? Txs

My feed seems to have recovered now.

1 Like

No joy, here, still no feed

Hi @dmarti32

Have you mapped the accounts like it shows in your screenshot (view the bank account > More Options > Activate Bank Feed)?

This would be the last step in linking the account. Until this is done, nothing is imported.