HOME / COMMUNITY Switch to knowledge base

Payment Terms not showing in sent invoice

Hi,
When I create an invoice, there is a field for Payments Terms. I use it for the bank details.

However, when I click Preview and Send, and go to the sent invoice that field is not showing up.

image

When I then click Modify Invoice I get the option to show the default terms

Why is that field not showing up straight away? Can I set this somewhere/somehow to show the default Payment Terms? And why is it showing in the draft but not in the sent invoice? I looked around in the forum and it looks like a few people had the same or similar question but most of the time it ended with a private message and a solution was not provided.

Thanks

Have you been messing with your invoice design settings and accidentally disabled that section?

Hi @rhc

It may be that you have changed something in your invoice style or if you’re using custom CSS you may have changed something which now hides that field?

If you could send links to the other threads I can take a look to see if I can find the outcomes from the private messages to help shed some light for you

Hi Beth,
Thanks for your quick reply. Here is the link:

I can’t see anything private with that user for that time, but I will ask @QFMathew to see if he can see anything and shed some light for us :slight_smile:

Hi @rhc

Can I just double check how these invoices without the default terms are being created?

Hi Mathew, Thanks for coming back to me. Your question made me thinking and I looked to the invoices. It looks like only on invoices brought in via zapier is the payments terms field missing. And that makes sense because those invoices, coming from my card machine and website, are already paid and don’t need the payments terms. Is that right?

Hi @rhc

I don’t think there’s an option for this for Zapier itself, although there’s an option to change things in the standard API, which was changed a few years back.

Where Terms or Notes is provided, but empty, it’s taken literally. Whereas if they’re omitted completely, we use the account default (see here. If you have this the option to remove the field completely, I would try that to see if it makes a difference.

1 Like

This topic was automatically closed after 7 days. New replies are no longer allowed.