HOME / COMMUNITY Switch to knowledge base

Problem Sending Invoices by email

Hello, I am very puzzled as to why an invoice is not being delivered by email to a customer? the invoice shows as successfully sent but it never arrives in the customers inbox or junk mail.
Can you point me in the right direction as to why this is happening. The email address is correct

Hi @JamesB

Are you using the default email setup, or have you changed it to your own SMTP setup?

If it’s the default, once the email has left our servers it’s difficult to understand why it doesn’t arrive, but it’s most likely to be down to the spam/junk filters on your clients end, filtering it out without any warning.

If a message is returned to us, you will see that the email has bounced from the client record. There’s more on this here.

Hi Matthew
I am using the default email set up and I cannot see any filtering or spam messages in the clients email set up

It has been known that emails to be rejected silently, as in the clients mail provider rejects it but doesn’t notify us or the receiver.

There are 2 ways to try and resolve this:

  1. Use the default noreply email address with your account, but this will prevent clients replying to your emails sent from QuickFile. Or,

  2. Use your own SMTP server.

If you already have an email account, SMTP may be the best option. It means all emails are then routed through your email server.

Please don’t hesitate to let me know if you need any help with either of these.

Hi Matthew
This is making me think i should check the email in the company set up

The email address in the company settings is used for invoices (if you display it). All emails are sent from mail@quickfile.co.uk and we add your specified email address, from the routine emails page, as a “reply-to”.

Not all mail servers like a reply-to, moreso when it’s different to the main domain it’s sent from (e.g. anything other than @quickfile.co.uk), which can cause it to be rejected or to bounce.

Keeping the mail@ email address should prevent this, but it means your clients can’t reply to you. If this is important, then the SMTP route should be a better option.

Hi Matthew
I have located the problem and you were absolutely correct with your first assumption.
There was a filter blocking the email and there was no Label for spam mail either so we could not see that it was treated as spam.
The settings in the clients email server has been amended and the emails from quick file are now being received.

Thanks for your help

1 Like

No problem at all! Glad to hear you got this working! :+1:

This topic was automatically closed after 7 days. New replies are no longer allowed.